aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-12-19 18:49:00 +0800
committerzeising <zeising@FreeBSD.org>2013-12-19 18:49:00 +0800
commitffd5eee971064a5f5d103743e960369e21b0d6a0 (patch)
treed1c6a110737ea4dde2a53b41b74670aeccf172ab /Mk
parent25615223f8adf63fceebd7b0378de73a5169a742 (diff)
downloadfreebsd-ports-gnome-ffd5eee971064a5f5d103743e960369e21b0d6a0.tar.gz
freebsd-ports-gnome-ffd5eee971064a5f5d103743e960369e21b0d6a0.tar.zst
freebsd-ports-gnome-ffd5eee971064a5f5d103743e960369e21b0d6a0.zip
Try to fix font handling for xorg fonts when using staging and pkgng.
This should silence all QAT messages about leftover font files. Bump portrevision for all affected ports. Original idea: bapt
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.xorg.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index 7d585780987d..a2ba2517b294 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -104,6 +104,19 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
. endif
post-install:
+.if defined(WITH_PKGNG)
+. for _fontdir in ${FONTDIR}
+. if ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == yes
+ @${ECHO_CMD} "@fcfontsdir lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. elif ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == no
+ @${ECHO_CMD} "@fc lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. elif ${NEED_MKFONTFOO} == yes
+ @${ECHO_CMD} "@fontsdir lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. else
+ @${ECHO_CMD} "@dirrmtry lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. endif
+. endfor
+.else
. if ${INSTALLS_TTF} == "yes"
. for _fontdir in ${FONTDIR}
@${ECHO_CMD} "@exec fc-cache -s %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
@@ -123,6 +136,7 @@ post-install:
@${ECHO_CMD} "@unexec rmdir %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
. endfor
. endif
+.endif
. if ${XORG_CAT} == "lib"
USES+= pathfix