aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-04-10 23:08:12 +0800
committermat <mat@FreeBSD.org>2017-04-10 23:08:12 +0800
commit0810f8e4e198cae9495224bbec2d93c730de667f (patch)
treed5e69465e01604b9397e3a29d671379e34329cef /Mk
parentd68f1a6c1992c88a23ae40c54453deea3872789a (diff)
downloadfreebsd-ports-gnome-0810f8e4e198cae9495224bbec2d93c730de667f.tar.gz
freebsd-ports-gnome-0810f8e4e198cae9495224bbec2d93c730de667f.tar.zst
freebsd-ports-gnome-0810f8e4e198cae9495224bbec2d93c730de667f.zip
Introduces USES=php:pecl.
It sets sane defaults when fetching from http://pecl.php.net/. Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D10281
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/php.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 9d5294590f20..3e0ac35bf4a0 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -15,6 +15,7 @@
# - mod : Want the Apache Module for PHP.
# - web : Want the Apache Module or the CGI version of PHP.
# - embed : Want the embedded library version of PHP.
+# - pecl : Fetches from PECL.
#
# If the port requires a predefined set of PHP extensions, they can be
# listed in this way:
@@ -89,6 +90,17 @@ DEV_WARNING+= "USES=php:phpize is included in USES=php:ext and USES=php:zend, so
. if ${php_ARGS:Mext} && ${php_ARGS:Mzend}
DEV_WARNING+= "USES=php:ext is included in USES=php:zend, so it is not needed"
. endif
+. if ${php_ARGS:Mext} && ${php_ARGS:Mpecl}
+DEV_WARNING+= "USES=php:ext is included in USES=php:pecl, so it is not needed"
+. endif
+
+. if ${php_ARGS:Mpecl}
+php_ARGS+= ext
+EXTRACT_SUFX= .tgz
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DIST_SUBDIR= PECL
+. endif
PHPBASE?= ${LOCALBASE}
. if exists(${PHPBASE}/etc/php.conf)