aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-30 00:55:02 +0800
committerbapt <bapt@FreeBSD.org>2012-05-30 00:55:02 +0800
commit09cc06a38d2d8760836535e4d50d4d8fadb62a2a (patch)
tree1105c97a154e25ca0e3043ca52c7c4511804f8ae /Mk
parentccb8bcfd6b5b9c1504ef0bfb34a8ca70dabc2c4c (diff)
downloadfreebsd-ports-gnome-09cc06a38d2d8760836535e4d50d4d8fadb62a2a.tar.gz
freebsd-ports-gnome-09cc06a38d2d8760836535e4d50d4d8fadb62a2a.tar.zst
freebsd-ports-gnome-09cc06a38d2d8760836535e4d50d4d8fadb62a2a.zip
Fix make config when cancel is hit
Reported by: ketas (via #bsdports)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 005d52f2b35a..97a872f2ea28 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6047,13 +6047,11 @@ config: pre-config
.endif
@TMPOPTIONSFILE=$$(mktemp -t portoptions); \
trap "${RM} -f $${TMPOPTIONSFILE}; exit 1" 1 2 3 5 10 13 15; \
- ${SH} -c '${DIALOG} --checklist "Options for ${PKGNAME:C/-([^-]+)$/ \1/}" 21 70 15 ${DEFOPTIONS}' 2> $${TMPOPTIONSFILE}; \
- status=$$?; \
- if [ $${status} -ne 0 ]; then \
+ ${SH} -c '${DIALOG} --checklist "Options for ${PKGNAME:C/-([^-]+)$/ \1/}" 21 70 15 ${DEFOPTIONS}' 2> $${TMPOPTIONSFILE} || { \
${RM} -f $${TMPOPTIONSFILE}; \
${ECHO_MSG} "===> Options unchanged"; \
exit 0; \
- fi; \
+ }; \
if [ ! -e $${TMPOPTIONSFILE} ]; then \
${ECHO_MSG} "===> No user-specified options to save for ${PKGNAME}"; \
exit 0; \