aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-09-03 09:13:10 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-09-03 09:13:10 +0800
commit0fcc4ef31239a9038ae83b62174d5e6785b4161e (patch)
tree7924d757255da07fa2d524e9da3229425313eb7a /Mk
parent30fa38fec5e792a5dc75e1093a01d7f1477861f9 (diff)
downloadfreebsd-ports-gnome-0fcc4ef31239a9038ae83b62174d5e6785b4161e.tar.gz
freebsd-ports-gnome-0fcc4ef31239a9038ae83b62174d5e6785b4161e.tar.zst
freebsd-ports-gnome-0fcc4ef31239a9038ae83b62174d5e6785b4161e.zip
- Fix regression from r325805 and allow 'make fetch' to work
without distinfo Reported by: sunpoet With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 746f484f8100..ce15e41d8738 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3432,7 +3432,7 @@ do-fetch:
esac; \
if ${SETENV} ${FETCH_ENV} ${FETCH_CMD} ${FETCH_BEFORE_ARGS} $${args} ${FETCH_AFTER_ARGS}; then \
actual_size=`stat -f %z "$${file}"`; \
- if [ -n "${DISABLE_SIZE}" ] || [ $${actual_size} -eq $${CKSIZE} ]; then \
+ if [ -n "${DISABLE_SIZE}" ] || [ -z "$${CKSIZE}" ] || [ $${actual_size} -eq $${CKSIZE} ]; then \
continue 2; \
else \
${ECHO_MSG} "=> Fetched file size mismatch (expected $${CKSIZE}, actual $${actual_size})"; \