aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-03-25 19:42:59 +0800
committerantoine <antoine@FreeBSD.org>2014-03-25 19:42:59 +0800
commit1f15b5c0951ef85f0fa86f2d24e752b594c35ca4 (patch)
tree63935708aad6cf362985081b8eff5a354a11ea47 /Mk
parent8afd430694dd4225be36fa28929f928d06f81f7d (diff)
downloadfreebsd-ports-gnome-1f15b5c0951ef85f0fa86f2d24e752b594c35ca4.tar.gz
freebsd-ports-gnome-1f15b5c0951ef85f0fa86f2d24e752b594c35ca4.tar.zst
freebsd-ports-gnome-1f15b5c0951ef85f0fa86f2d24e752b594c35ca4.zip
Allow distfiles grouping for linux-rpm ports while not extracting the .src.rpm on the package builders
With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.linux-rpm.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index ddb98b1396bd..4a3c3cdb74e4 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -95,9 +95,9 @@ PKGNAMEPREFIX?= linux-
# is not true.
DISTFILES?= ${DISTNAME}${EXTRACT_SUFX}
-BIN_DISTFILES:= ${_DISTFILES}
+BIN_DISTFILES:= ${DISTFILES}
SRC_DISTFILES?= ${DISTNAME}${SRC_SUFX}
-EXTRACT_ONLY?= ${BIN_DISTFILES}
+EXTRACT_ONLY?= ${BIN_DISTFILES:C/:[^:]+$//}
. if defined(PACKAGE_BUILDING)
DISTFILES+= ${SRC_DISTFILES}