aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2010-11-30 21:03:10 +0800
committerbeat <beat@FreeBSD.org>2010-11-30 21:03:10 +0800
commit2d4d3a4af8d37c385bb546ecb6c22f2be3b53891 (patch)
treef33c34fe075c9131f83ef05a076967bd4f1d285b /Mk
parent706d809a250acc85151f6babc648322d8215acca (diff)
downloadfreebsd-ports-gnome-2d4d3a4af8d37c385bb546ecb6c22f2be3b53891.tar.gz
freebsd-ports-gnome-2d4d3a4af8d37c385bb546ecb6c22f2be3b53891.tar.zst
freebsd-ports-gnome-2d4d3a4af8d37c385bb546ecb6c22f2be3b53891.zip
- Change gecko master port from www/mozilla to www/seamonkey.
- Switch substitution example to libxul-devel<->libxul although this functionality is not used as the ports tree does not have libxul-devel at the moment.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 9ac886aa28e5..97f1a439429e 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -53,9 +53,9 @@ Gecko_Pre_Include= bsd.gecko.mk
# will be the default. In the above example, www/libxul will be used
# as a gecko backend unless WITH_GECKO=seamonkey is defined by the user.
#
-# USE_GECKO= firefox-devel<->firefox
-# This will sed -e 's/firefox/firefox-devel/' on Makefile.in's and configure
-# if ${GECKO}=="firefox-devel"
+# USE_GECKO= libxul-devel<->libxul
+# This will sed -e 's/libxul/libxul-devel/' on Makefile.in's and configure
+# if ${GECKO}=="libxul-devel"
#
# Example:
# USE_GECKO= libxul seamonkey
@@ -259,7 +259,7 @@ FAKEDIR?= ${WRKDIR}/fake
PLIST?= ${WRKDIR}/plist
PLISTD?= ${WRKDIR}/plist_dirs
PLISTF?= ${WRKDIR}/plist_files
-MASTER_DIR?= ${.CURDIR}/../../www/mozilla
+MASTER_DIR?= ${.CURDIR}/../../www/seamonkey
KRB5_HOME?= /usr
MOZ_PIS_DIR?= lib/${MOZILLA}/init.d
@@ -267,14 +267,14 @@ MOZ_PIS_DIR?= lib/${MOZILLA}/init.d
ESD_LIB?= libesd.so.2
FREETYPE_LIB?= libfreetype.so.9
-GENERIC_MOZCONFIG?= ${.CURDIR}/../../www/mozilla/files/mozconfig-generic.in
+GENERIC_MOZCONFIG?= ${.CURDIR}/../../www/seamonkey/files/mozconfig-generic.in
PORT_MOZCONFIG?= ${FILESDIR}/mozconfig.in
MOZCONFIG?= ${WRKSRC}/.mozconfig
MOZILLA_PLIST_DIRS?= bin include lib share/idl
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread: | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
PKGINSTALL?= ${WRKDIR}/pkg-install
PKGDEINSTALL?= ${WRKDIR}/pkg-deinstall
-MASTER_MOZDIR?= ${PORTSDIR}/www/mozilla
+MASTER_MOZDIR?= ${PORTSDIR}/www/seamonkey
PKGINSTALL_INC?= ${MASTER_MOZDIR}/pkg-install.in
PKGDEINSTALL_INC?= ${MASTER_MOZDIR}/pkg-deinstall.in