aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-08-31 21:56:08 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-08-31 21:56:08 +0800
commit570c1b2878d70c44053b72e62e70486a2967feeb (patch)
tree51eb0b479540ae133f43750381f2279e19e9ab3b /Mk
parent77f1590c0a5853077a176a0d971cf35ae2c35266 (diff)
downloadfreebsd-ports-gnome-570c1b2878d70c44053b72e62e70486a2967feeb.tar.gz
freebsd-ports-gnome-570c1b2878d70c44053b72e62e70486a2967feeb.tar.zst
freebsd-ports-gnome-570c1b2878d70c44053b72e62e70486a2967feeb.zip
- Add USE_PACKAGE_DEPENDS_ONLY which will try installing dependencies
from existing packages and not fallback on building from source. This is useful for package building tools such as poudriere and tinderbox to avoid building from source and confusing the build log, if a dependency failed to build for some reason. NOTE: USE_PACKAGE_DEPENDS has not changed here. It has always reverted to source if the package was not present. PR: ports/180725 Submitted by: crees With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index aa3a17a94ddd..1b772b6a1118 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1084,8 +1084,11 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# a different checksum and you intend to verify if
# the port still works with it.
# USE_PACKAGE_DEPENDS
-# - Install dependencies from existing packages instead
-# of building the port from scratch.
+# - Try to install dependencies from existing packages instead
+# of building the port from scratch. Fallback on source
+# if an existing package is not present.
+# USE_PACKAGE_DEPENDS_ONLY
+# - Like USE_PACKAGE_DEPENDS, but do not fallback on source.
# INSTALL_AS_USER
# - Define this to install as the current user, intended
# for systems where you have no root access.
@@ -4906,7 +4909,7 @@ _DEPEND_ALWAYS= 0
.endif
_INSTALL_DEPENDS= \
- if [ X${USE_PACKAGE_DEPENDS} != "X" ]; then \
+ if [ -n "${USE_PACKAGE_DEPENDS}" -o -n "${USE_PACKAGE_DEPENDS_ONLY}" ]; then \
subpkgfile=`(cd $$dir; ${MAKE} $$depends_args -V PKGFILE)`; \
subpkgname=$${subpkgfile%-*} ; \
subpkgname=$${subpkgname\#\#*/} ; \
@@ -4920,6 +4923,10 @@ _INSTALL_DEPENDS= \
else \
${PKG_ADD} $${subpkgfile}; \
fi; \
+ elif [ -n "${USE_PACKAGE_DEPENDS_ONLY}" ]; then \
+ ${ECHO_MSG} "===> ${PKGNAME} depends on package: $${subpkgfile} - not found"; \
+ ${ECHO_MSG} "===> USE_PACKAGE_DEPENDS_ONLY set - will not build from source"; \
+ exit 1; \
else \
(cd $$dir; ${MAKE} -DINSTALLS_DEPENDS $$target $$depends_args) ; \
fi; \