aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-22 21:36:05 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-22 21:36:05 +0800
commit576fd129d225e87e33d22de37cd62912af6278f3 (patch)
treeb3488e1392115f0ca1ca52c0fba05c04d8237526 /Mk
parent61bd243a2f0e59fd847e550ad776032dea0cea9d (diff)
downloadfreebsd-ports-gnome-576fd129d225e87e33d22de37cd62912af6278f3.tar.gz
freebsd-ports-gnome-576fd129d225e87e33d22de37cd62912af6278f3.tar.zst
freebsd-ports-gnome-576fd129d225e87e33d22de37cd62912af6278f3.zip
- Add shebangfix documentation bits
- Fix tcl_OLD_CMD tk_OLD_CMD Approved by: portmgr (bapt) Differential Revision: D3939
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/shebangfix.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/Mk/Uses/shebangfix.mk b/Mk/Uses/shebangfix.mk
index d98e52eaf85d..520cec286c90 100644
--- a/Mk/Uses/shebangfix.mk
+++ b/Mk/Uses/shebangfix.mk
@@ -13,6 +13,11 @@
#
# SHEBANG_FILES= path1/file path2/*.pl
#
+# To define custom shebangs to replace, use the following (note that
+# shebangs with spaces should be quoted):
+#
+# perl_OLD_CMD= /usr/bin/perl5.005 "/usr/bin/setenv perl5.005"
+#
# To define a new shebang scheme add the following to the port Makefile:
#
# SHEBANG_LANG= lua
@@ -36,8 +41,11 @@ SHEBANG_LANG+= lua
lua_CMD?= ${LOCALBASE}/bin/${LUA_CMD}
.endif
-tcl_CMD?= ${TCLSH}
-tk_CMD?= ${WISH}
+tcl_OLD_CMD+= /usr/bin/tclsh
+tcl_CMD?= ${TCLSH}
+
+tk_OLD_CMD+= /usr/bin/wish
+tk_CMD?= ${WISH}
.if ${USES:Mpython*}
python_CMD?= ${PYTHON_CMD}