aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-03-30 03:03:17 +0800
committertcberner <tcberner@FreeBSD.org>2018-03-30 03:03:17 +0800
commit63c259ca10bd425e19413bfa43d923baee86a1d4 (patch)
tree5830350c230c42b929c6bc665e376f2852edce93 /Mk
parent087918eb2302a4446c0110d6db410278b3ae3e6c (diff)
downloadfreebsd-ports-gnome-63c259ca10bd425e19413bfa43d923baee86a1d4.tar.gz
freebsd-ports-gnome-63c259ca10bd425e19413bfa43d923baee86a1d4.tar.zst
freebsd-ports-gnome-63c259ca10bd425e19413bfa43d923baee86a1d4.zip
Fix permissions in installed Qt5 header files
For the qt5-* ports bsd.qt.mk sets EXTRACT_AFTER_ARGS, and thereby does not get the normal default value of --no-same-owner --no-same-permissions passed when extracting. This lead to for example header files being installed (i.e. copied), with permissions group write permissions. Manually append that to the bsd.qt.mk shenanigans (also do the same in www/qt5-webchannel, which opts out of the bsd.qt.mk value) PR: 227027 Reported by: grarpamp@gmail.com
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.qt.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 4b8b89bfbffb..b65823ece023 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -107,7 +107,8 @@ USES+= pkgconfig
# Other ports from other Qt modules will automatically build examples and
# tests if the directories exist because of mkspecs/features/qt_parts.prf.
EXTRACT_AFTER_ARGS?= ${DISTNAME:S,$,/examples,:S,^,--exclude ,} \
- ${DISTNAME:S,$,/tests,:S,^,--exclude ,}
+ ${DISTNAME:S,$,/tests,:S,^,--exclude ,} \
+ --no-same-owner --no-same-permissions
. endif # ! ${_QT_VERSION:M4*}
CONFIGURE_ENV+= MAKE="${MAKE:T}"