aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-04-10 06:40:20 +0800
committerpav <pav@FreeBSD.org>2009-04-10 06:40:20 +0800
commit7b865cba9d46f455897fb9a5234e235c42865458 (patch)
tree0a70b2ca5d143a72995fafa9f2fdda761f536561 /Mk
parenta93a8f90c5f5e032d5443b5b3fe6fd32be20c906 (diff)
downloadfreebsd-ports-gnome-7b865cba9d46f455897fb9a5234e235c42865458.tar.gz
freebsd-ports-gnome-7b865cba9d46f455897fb9a5234e235c42865458.tar.zst
freebsd-ports-gnome-7b865cba9d46f455897fb9a5234e235c42865458.zip
- Don't check if pkg_tools support conflicts, they do on all recent FreeBSD
versions. This removes one != call per port, shaving off 2 minutes of CPU time per INDEX build on my computer. Tested by: pointyhat build run
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 0 insertions, 8 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 481c5bf5fee9..5558ab6cee96 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2383,14 +2383,6 @@ PKG_INFO?= /usr/sbin/pkg_info
PKG_VERSION?= /usr/sbin/pkg_version
.endif
-# Does the pkg_create tool support conflict checking?
-# XXX Slow?
-.if !defined(PKGINSTALLVER)
-PKGINSTALLVER!= ${PKG_INFO} -P 2>/dev/null | ${SED} -e 's/.*: //'
-.endif
-.if ${PKGINSTALLVER} < 20030417
-DISABLE_CONFLICTS= YES
-.endif
.if !defined(PKG_ARGS)
PKG_ARGS= -v -c -${COMMENT:Q} -d ${DESCR} -f ${TMPPLIST} -p ${PREFIX} -P "`cd ${.CURDIR} && ${MAKE} actual-package-depends | ${GREP} -v -E ${PKG_IGNORE_DEPENDS} | ${SORT} -u -t : -k 2`" ${EXTRA_PKG_ARGS} $${_LATE_PKG_ARGS}
.if !defined(NO_MTREE)