aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2018-03-03 09:18:50 +0800
committerbdrewery <bdrewery@FreeBSD.org>2018-03-03 09:18:50 +0800
commit823777346dbf8636b09a6fd8f7e4c883071886a6 (patch)
treeb3afd15dc53e39a65de69f476030b82b66eca51d /Mk
parent7ac0b046c4e00bc8aeced60d4eae0395ceebfff2 (diff)
downloadfreebsd-ports-gnome-823777346dbf8636b09a6fd8f7e4c883071886a6.tar.gz
freebsd-ports-gnome-823777346dbf8636b09a6fd8f7e4c883071886a6.tar.zst
freebsd-ports-gnome-823777346dbf8636b09a6fd8f7e4c883071886a6.zip
Avoid double exporting PORTS_ENV.
Approved by: portmgr (implicit)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/functions.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/Scripts/functions.sh b/Mk/Scripts/functions.sh
index 096d50efff5a..0aa7a1ed0c2a 100644
--- a/Mk/Scripts/functions.sh
+++ b/Mk/Scripts/functions.sh
@@ -162,6 +162,10 @@ validate_env() {
export_ports_env() {
local export_vars make_cmd make_env var results value uses
+ if [ -n "${HAVE_PORTS_ENV:-}" ]; then
+ return 0
+ fi
+
validate_env MAKE PORTSDIR
uses="python compiler:features"
@@ -197,6 +201,8 @@ export_ports_env() {
echo "export ${var}=\"${value}\""
fi
done
+ export HAVE_PORTS_ENV=1
+ echo "export HAVE_PORTS_ENV=1"
}
distinfo_data() {