aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-02-27 03:33:21 +0800
committerantoine <antoine@FreeBSD.org>2018-02-27 03:33:21 +0800
commit8f49b02be64984f8f76196cbf8e64c1bd5843dba (patch)
treeee9d24f830ba95aea6b8e81747d10eca5fdaf115 /Mk
parentf73545dc96e13c51dc92d3985bd33cd7d34ea30a (diff)
downloadfreebsd-ports-gnome-8f49b02be64984f8f76196cbf8e64c1bd5843dba.tar.gz
freebsd-ports-gnome-8f49b02be64984f8f76196cbf8e64c1bd5843dba.tar.zst
freebsd-ports-gnome-8f49b02be64984f8f76196cbf8e64c1bd5843dba.zip
Remove support for deprecated USES=python:2 and USES=python:3
PR: 225752 With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk18
1 files changed, 4 insertions, 14 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index ac9cb699c386..46d6bc8c4c77 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -10,15 +10,13 @@
#
# version If your port requires only some set of Python versions, you
# can set this to [min]-[max] or min+ or -max or as an
-# explicit version or as a meta port version (eg. 3.3-3.4 for
-# [min]-[max], 2.7+ or -3.3 for min+ and -max, 2.7 for an
-# explicit version or 3 for a meta port version). Example:
+# explicit version (eg. 3.3-3.4 for [min]-[max], 2.7+ or -3.3
+# for min+ and -max, 2.7 for an explicit version). Example:
#
# USES=python:2.7 # Only use Python 2.7
# USES=python:3.3+ # Use Python 3.3 or newer
# USES=python:3.3-3.4 # Use Python 3.3 or 3.4
# USES=python:-3.3 # Use any Python up to 3.3
-# USES=python:2 # Use the Python 2 meta port
# USES=python # Use the set default Python
# # version
#
@@ -306,15 +304,10 @@ _PYTHON_TEST_DEP= yes
WARNING+= "PYTHON_DEFAULT must be a version present in PYTHON2_DEFAULT or PYTHON3_DEFAULT, if you want more Python flavors, set BUILD_ALL_PYTHON_FLAVORS in your make.conf"
.endif
-# Keep this before the FLAVOR selection to get the meta port dependency.
.if ${_PYTHON_ARGS} == "2"
-_PYTHON_ARGS= ${PYTHON2_DEFAULT}
-_WANTS_META_PORT= 2
-DEV_WARNING+= "USES=python:2 is deprecated, use USES=python:2.7"
+DEV_ERROR+= "USES=python:2 is no longer supported, use USES=python:2.7"
.elif ${_PYTHON_ARGS} == "3"
-_PYTHON_ARGS= ${PYTHON3_DEFAULT}
-_WANTS_META_PORT= 3
-DEV_WARNING+= "USES=python:3 is deprecated, use USES=python:3.4+ or an appropriate version range"
+DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.4+ or an appropriate version range"
.endif # ${_PYTHON_ARGS} == "2"
.if defined(PYTHON_VERSION)
@@ -682,9 +675,6 @@ PY_BOOST= lib${PY_BOOST_LIB}.so:devel/boost-python-libs@${PY_FLAVOR}
.for _stage in PATCH BUILD RUN TEST
. if defined(_PYTHON_${_stage}_DEP)
${_stage}_DEPENDS+= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
-. if defined(_WANTS_META_PORT)
-${_stage}_DEPENDS+= python${_WANTS_META_PORT}:${_PYTHON_RELPORTDIR}${_WANTS_META_PORT}
-. endif
. endif
.endfor