aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-23 00:16:46 +0800
committerbapt <bapt@FreeBSD.org>2013-04-23 00:16:46 +0800
commitb0b0df36edd2b389ca6e24e03e62dbc98e86f661 (patch)
treee88bb14bbaf3cb0a8bc52d9b8f7784e8eb586912 /Mk
parent9baf30a47c7f67b98ea8767e778cef6363d5ad50 (diff)
downloadfreebsd-ports-gnome-b0b0df36edd2b389ca6e24e03e62dbc98e86f661.tar.gz
freebsd-ports-gnome-b0b0df36edd2b389ca6e24e03e62dbc98e86f661.tar.zst
freebsd-ports-gnome-b0b0df36edd2b389ca6e24e03e62dbc98e86f661.zip
Add a global config.site cache.
This has 2 effects: - it caches lots of things autotools are looking for and we know that are already on FreeBSD (speeding up configure scripts) - it forces the autotool enable build chain to use by default commands from the base system like sed, awk, cp, bzip2, gzip etc To overwrite things set in config.site just add the variable in CONFIGURE_ENV within your port Please help us to add new values in this config.site
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 41d42bf92280..3a01fa176819 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2947,7 +2947,7 @@ CONFIGURE_MAX_CMD_LEN!= ${SYSCTL} -n kern.argmax
.endif
GNU_CONFIGURE_PREFIX?= ${PREFIX}
CONFIGURE_ARGS+= --prefix=${GNU_CONFIGURE_PREFIX} $${_LATE_CONFIGURE_ARGS}
-CONFIGURE_ENV+= lt_cv_sys_max_cmd_len=${CONFIGURE_MAX_CMD_LEN}
+CONFIGURE_ENV+= CONFIG_SITE=${PORTSDIR}/Templates/config.site lt_cv_sys_max_cmd_len=${CONFIGURE_MAX_CMD_LEN}
HAS_CONFIGURE= yes
SET_LATE_CONFIGURE_ARGS= \