aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>2002-03-17 06:47:00 +0800
committermarkm <markm@FreeBSD.org>2002-03-17 06:47:00 +0800
commitb9611253005575d44c33df612983e8d507160044 (patch)
tree3f15ad2da0102a3d4f44203ff55d98a3909b18ea /Mk
parent83d465443489a6b29d521f616548bfcd2fa50113 (diff)
downloadfreebsd-ports-gnome-b9611253005575d44c33df612983e8d507160044.tar.gz
freebsd-ports-gnome-b9611253005575d44c33df612983e8d507160044.tar.zst
freebsd-ports-gnome-b9611253005575d44c33df612983e8d507160044.zip
Take Perl 5.6.1 into account. Allow for slow updaters who prefer to
stay with an older CURRENT and perl 5.6.0.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 6577bf60af58..049ebbc3fb22 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -968,6 +968,11 @@ BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
.endif
.endif
+.if ${OSVERSION} >= 500032
+PERL_VERSION?= 5.6.1
+PERL_VER?= 5.6.1
+PERL_ARCH?= mach
+.else
.if ${OSVERSION} >= 500007
PERL_VERSION?= 5.6.0
PERL_VER?= 5.6.0
@@ -981,6 +986,7 @@ PERL_VERSION?= 5.00502
PERL_VER?= 5.005
PERL_ARCH?= ${ARCH}-freebsd
.endif
+.endif
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PERL_VER=${PERL_VER} \
PERL_ARCH=${PERL_ARCH}