aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-10-12 23:57:51 +0800
committermat <mat@FreeBSD.org>2017-10-12 23:57:51 +0800
commitc0753cee143fae1f39b92cb83a9d69070eb901d7 (patch)
tree22d06d881d39a3e8bbe4216cf9029a239cf1e2dc /Mk
parentc8fa612661c5330a15b421fc2f28b32ff8d9c89e (diff)
downloadfreebsd-ports-gnome-c0753cee143fae1f39b92cb83a9d69070eb901d7.tar.gz
freebsd-ports-gnome-c0753cee143fae1f39b92cb83a9d69070eb901d7.tar.zst
freebsd-ports-gnome-c0753cee143fae1f39b92cb83a9d69070eb901d7.zip
Remove WANT_GNOME and HAVE_GNOME.
Approved by: bapt kwm Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12643
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gnome.mk73
-rw-r--r--Mk/bsd.sanity.mk3
2 files changed, 2 insertions, 74 deletions
diff --git a/Mk/Uses/gnome.mk b/Mk/Uses/gnome.mk
index 3c7d12fc2804..63e3dbd4e244 100644
--- a/Mk/Uses/gnome.mk
+++ b/Mk/Uses/gnome.mk
@@ -477,70 +477,6 @@ USE_GNOME+= gtk-update-icon-cache
# End component definition section
-# This section defines tests for optional software. These work off four
-# types of variables: WANT_GNOME, WITH_GNOME, HAVE_GNOME and USE_GNOME.
-# The logic of this is that a port can WANT support for a package; a user
-# specifies if they want ports compiled WITH certain features; this section
-# tests if we HAVE these features; and the port is then free to USE them.
-
-# The logic of this section is like this:
-#
-# .if defined(WANT_GNOME) && !defined(WITHOUT_GNOME)
-# .for foo in ALL_GNOME_COMPONENTS
-# .if defined(WITH_GNOME)
-# HAVE_GNOME += foo
-# .elif (foo installed)
-# HAVE_GNOME += foo
-# .else
-# Print option message
-# .endif
-# .endfor
-# .endif
-#
-# Although it appears a little more convoluted in the tests.
-
-# Ports can make use of this like so:
-#
-# WANT_GNOME= yes
-#
-# .include <bsd.port.pre.mk>
-#
-# .if ${HAVE_GNOME:Mfoo}!=""
-# ... Do some things ...
-# USE_GNOME= foo
-# .else
-# ... Do some other things ...
-# .endif
-
-# We also check each component to see if it has a desktop requirement. If
-# it does, and its requirement disagrees with the user's chosen desktop,
-# do not add the component to the HAVE_GNOME list.
-
-_USE_GNOME_SAVED:=${USE_GNOME}
-HAVE_GNOME?=
-.if (defined(WANT_GNOME) && !defined(WITHOUT_GNOME))
-. for component in ${_USE_GNOME_ALL}
-. if exists(${${component}_DETECT})
-HAVE_GNOME+= ${component}
-. elif defined(WITH_GNOME)
-. if ${WITH_GNOME}=="yes" || ${WITH_GNOME:M${component}}!="" \
- || ${WITH_GNOME}=="1"
-HAVE_GNOME+= ${component}
-. endif
-. endif
-. endfor
-.elif defined(WITHOUT_GNOME)
-. if ${WITHOUT_GNOME}!="yes" && ${WITHOUT_GNOME}!="1"
-. for component in ${_USE_GNOME_ALL}
-. if ${WITHOUT_GNOME:M${component}}==""
-. if exists(${${component}_DETECT})
-HAVE_GNOME+= ${component}
-. endif
-. endif
-. endfor
-. endif
-.endif
-
.if defined(USE_GNOME)
# First of all expand all USE_GNOME_IMPL recursively
. for component in ${_USE_GNOME_ALL}
@@ -629,15 +565,6 @@ MAKE_ENV+= GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
. endif
.endif
-.if defined(WANT_GNOME)
-USE_GNOME?=
-. if ${_USE_GNOME_SAVED}==${USE_GNOME}
-PLIST_SUB+= GNOME:="@comment " NOGNOME:=""
-. else
-PLIST_SUB+= GNOME:="" NOGNOME:="@comment "
-. endif
-.endif
-
.if defined(USE_GNOME_SUBR)
GNOME_SUBR= ${LOCALBASE}/etc/gnome.subr
RUN_DEPENDS+= ${GNOME_SUBR}:sysutils/gnome_subr
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index cf9d5771e899..ceb155e31391 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -179,7 +179,7 @@ SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_PYTHON_PREFIX USE_BZIP2 USE_XZ USE_PGSQL NEED_ROOT \
UNIQUENAME LATEST_LINK USE_SQLITE USE_FIREBIRD USE_PHPEXT \
USE_ZENDEXT USE_PHP_BUILD USE_BDB PLIST_DIRSTRY USE_RCORDER \
- USE_OPENSSL
+ USE_OPENSSL WANT_GNOME
SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS \
USE_MYSQL WANT_MYSQL_VER \
USE_PHPIZE WANT_PHP_CLI WANT_PHP_CGI WANT_PHP_MOD \
@@ -239,6 +239,7 @@ WANT_PHP_MOD_ALT= USES=php:mod
WANT_PHP_WEB_ALT= USES=php:web
WANT_PHP_EMB_ALT= USES=php:embed
USE_RCORDER_ALT= USE_RC_SUBR=${USE_RCORDER}
+WANT_GNOME_ALT= USES=gnome
.for a in ${SANITY_DEPRECATED}
.if defined(${a})