aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-07-27 03:19:20 +0800
committerrene <rene@FreeBSD.org>2013-07-27 03:19:20 +0800
commitc945ab9477002608dac69f344be7d3f1f1b7d511 (patch)
tree4c98d494bc4532b5dd5b19f4e47bcb3babf104c2 /Mk
parent16876857cc4291ce83cf938fde7ea3a988e9a904 (diff)
downloadfreebsd-ports-gnome-c945ab9477002608dac69f344be7d3f1f1b7d511.tar.gz
freebsd-ports-gnome-c945ab9477002608dac69f344be7d3f1f1b7d511.tar.zst
freebsd-ports-gnome-c945ab9477002608dac69f344be7d3f1f1b7d511.zip
KDE3 and QT3 expired on 2013-07-01, remove these ports.
Unfortunately, this also affects some ports using QT3 as a GUI toolkit. Changes to infrastructure files: - bsd.kde.mk : obsolete, remove - bsd.qt.mk : note that a CONFLICTS_BUILD line can probably go after a while - CHANGES : document the removals from bsd.port.mk - KNOBS : remove KDE and QT (KDE4 and QT4 should be used instead) - MOVED : add the removed ports PR: ports/180745 Submitted by: rene Approved by: portmgr (bapt) Exp-run by: bapt
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.kde.mk153
-rw-r--r--Mk/bsd.qt.mk1
2 files changed, 1 insertions, 153 deletions
diff --git a/Mk/bsd.kde.mk b/Mk/bsd.kde.mk
deleted file mode 100644
index e681324c4294..000000000000
--- a/Mk/bsd.kde.mk
+++ /dev/null
@@ -1,153 +0,0 @@
-#-*- tab-width: 4; -*-
-# ex:ts=4
-#
-# $FreeBSD$
-#
-# Please view me with 4 column tabs!
-
-# Please make sure all changes to this file are past through the maintainer.
-# Do not commit them yourself (unless of course you're the Port's Wraith ;).
-KDE_MAINTAINER= kde@FreeBSD.org
-
-# This section contains the USE_ definitions.
-# XXX: Write HAVE_ definitions sometime.
-
-# USE_QT_VER - Says that the port uses the Qt toolkit. Possible values:
-# 3, 4; each specify the major version of Qt to use.
-# Note: 4 is handled by bsd.qt.mk.
-# USE_KDELIBS_VER - Says that the port uses KDE libraries. Possible values:
-# 3 specifies the major version of KDE to use.
-# This implies USE_QT of the appropriate version.
-# USE_KDEBASE_VER - Says that the port uses the KDE base. Possible values:
-# 3 specifies the major version of KDE to use.
-# This implies USE_KDELIBS of the appropriate version.
-
-# tagged MASTER_SITE_KDE_kde
-kmaster= ${MASTER_SITE_KDE:S@%/@%/:kde@g}
-.if !defined(MASTER_SITE_SUBDIR)
-MASTER_SITE_KDE_kde= ${kmaster:S@%SUBDIR%/@@g}
-.else
-ksub=${MASTER_SITE_SUBDIR}
-MASTER_SITE_KDE_kde= ${kmaster:S@%SUBDIR%/@${ksub}/@g}
-.endif # !defined(MASTER_SITE_SUBDIR)
-
-# USE_KDEBASE_VER section
-.if defined(USE_KDEBASE_VER)
-.if ${USE_KDEBASE_VER} == CVS
-LIB_DEPENDS+= kfontinst.0:${PORTSDIR}/x11/kdebase
-USE_KDELIBS_VER=CVS
-.elif ${USE_KDEBASE_VER} == 3
-# kdebase 3.x common stuff
-LIB_DEPENDS+= kfontinst.0:${PORTSDIR}/x11/kdebase3
-USE_KDELIBS_VER=3
-.endif # ${USE_KDEBASE_VER} == 3
-.endif # defined(USE_KDEBASE_VER)
-
-# USE_KDELIBS_VER section
-.if defined(USE_KDELIBS_VER)
-
-## This is needed for configure scripts to figure out
-## which threads lib to use
-
-CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
-
-## Every KDE application is inherently IPv6-capable
-
-CATEGORIES+=ipv6
-
-## XXX - This really belongs into bsd.port.mk
-.if !defined(_NO_KDE_CONFTARGET_HACK)
-CONFIGURE_ARGS+=--x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include \
- --disable-as-needed
-.endif
-
-.if ${USE_KDELIBS_VER} == CVS
-LIB_DEPENDS+= kimproxy.0:${PORTSDIR}/x11/kdelibs
-USE_QT_VER= CVS
-PREFIX= ${KDE_CVS_PREFIX}
-.elif ${USE_KDELIBS_VER} == 3
-# kdelibs 3.x common stuff
-LIB_DEPENDS+= kimproxy.0:${PORTSDIR}/x11/kdelibs3
-USE_QT_VER= 3
-PREFIX= ${KDE_PREFIX}
-.else
-IGNORE= cannot install: unsupported value in USE_KDELIBS_VER
-.endif # ${USE_KDELIBS_VER} == 3
-.endif # defined(USE_KDELIBS_VER)
-
-# End of USE_KDELIBS_VER section
-
-# USE_QT_VER section
-.if ${USE_QT_VER} == CVS
-
-KDE_CVS_PREFIX?= ${LOCALBASE}/kde-cvs
-QT_CVS_PREFIX?= ${LOCALBASE}/qt-cvs
-QTCPPFLAGS?=
-QTCFGLIBS?=
-
-MOC?= ${QT_CVS_PREFIX}/bin/moc
-BUILD_DEPENDS+= ${MOC}:${PORTSDIR}/x11-toolkits/qt-copy
-RUN_DEPENDS+= ${MOC}:${PORTSDIR}/x11-toolkits/qt-copy
-QTCPPFLAGS+= -D_GETOPT_H # added to work around broken getopt.h #inc
-.if !defined (QT_NONSTANDARD)
-CONFIGURE_ARGS+=--with-extra-libs="${LOCALBASE}/lib" \
- --with-extra-includes="${LOCALBASE}/include"
-CONFIGURE_ENV+= MOC="${MOC}" LIBS="${QTCFGLIBS}" \
- QTDIR="${QT_CVS_PREFIX}" KDEDIR="${KDE_CVS_PREFIX}"
-CPPFLAGS+= ${QTCPPFLAGS}
-.endif
-
-.elif ${USE_QT_VER} == 3
-
-# Yeah, it's namespace pollution, but this is really the best place for this
-# stuff. Arts does NOT use it anymore.
-KDE_VERSION= 3.5.10
-KDE_ORIGVER= ${KDE_VERSION}
-KDE_PREFIX?= ${LOCALBASE}
-
-QTCPPFLAGS?=
-QTCGFLIBS?=
-
-# Qt 3.x common stuff
-QT_PREFIX?= ${LOCALBASE}
-MOC?= ${QT_PREFIX}/bin/moc
-#LIB_DEPENDS+= qt-mt.3:${PORTSDIR}/x11-toolkits/qt33
-BUILD_DEPENDS+= ${QT_PREFIX}/bin/moc:${PORTSDIR}/x11-toolkits/qt33
-RUN_DEPENDS+= ${QT_PREFIX}/bin/moc:${PORTSDIR}/x11-toolkits/qt33
-QTCPPFLAGS+= -I${LOCALBASE}/include -I${PREFIX}/include \
- -I${QT_PREFIX}/include -D_GETOPT_H
-QTCFGLIBS+= -Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg \
- -L${QT_PREFIX}/lib
-
-.if !defined(QT_NONSTANDARD)
-CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
- --with-qt-libraries=${QT_PREFIX}/lib \
- --with-extra-libs=${LOCALBASE}/lib \
- --with-extra-includes=${LOCALBASE}/include
-CONFIGURE_ENV+= MOC="${MOC}" LIBS="${QTCFGLIBS}" \
- QTDIR="${QT_PREFIX}" KDEDIR="${KDE_PREFIX}"
-CPPFLAGS+= ${QTCPPFLAGS}
-.endif # !defined(QT_NONSTANDARD)
-
-.else
-IGNORE= cannot install: unsupported value of USE_QT_VER
-.endif # defined(USE_QT_VER)
-
-# End of USE_QT_VER section
-
-# Assemble plist from parts
-# <alane@freebsd.org> 2002-12-06
-.if defined(KDE_BUILD_PLIST)
-PLIST?= ${WRKDIR}/plist
-PLIST_BASE?= plist.base
-PLIST_APPEND?=
-plist_base=${FILESDIR}/${PLIST_BASE}
-plist_base_rm=${FILESDIR}/${PLIST_BASE}.rm
-plist_append=${PLIST_APPEND:C:([A-Za-z0-9._]+):${FILESDIR}/\1:}
-plist_append_rm=${PLIST_APPEND:C:([A-Za-z0-9._]+):${FILESDIR}/\1.rm:}
-kde-plist:
- ${CAT} ${plist_base} ${plist_append} 2>/dev/null >${PLIST}
- -${CAT} ${plist_append_rm} ${plist_base_rm} 2>/dev/null >>${PLIST};true
-.PHONY: kde-plist
-pre-build: kde-plist
-.endif # defined(KDE_BUILD_PLIST)
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 93f3edf520c1..a00da8a09b06 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -34,6 +34,7 @@ DISTNAME= qt-everywhere-opensource-src-${QT4_VERSION}
DIST_SUBDIR= KDE
#CONFLICTS+= Currently there are no conflicts \o/
+# rene: can go after a while
CONFLICTS_BUILD= qt-3.* qt-copy-3.*
# Let configure handle its well known compilers defined in the mkspecs