aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-01-05 16:15:53 +0800
committerasami <asami@FreeBSD.org>1995-01-05 16:15:53 +0800
commitcdaeecda1e5f39ed9773f10273545ee662838638 (patch)
tree9574e66afe7fa6b07326d881c0a4d3c223fd1981 /Mk
parent678e2d00b4b112671537999dca2b840d23049818 (diff)
downloadfreebsd-ports-gnome-cdaeecda1e5f39ed9773f10273545ee662838638.tar.gz
freebsd-ports-gnome-cdaeecda1e5f39ed9773f10273545ee662838638.tar.zst
freebsd-ports-gnome-cdaeecda1e5f39ed9773f10273545ee662838638.zip
Sort out dependencies. Now they look like:
patch: extract configure: depends patch build: configure install: build Does this look ok?
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 3fba8bb41e50..2e018e39867f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.95 1995/01/04 23:06:38 jkh Exp $
+# $Id: bsd.port.mk,v 1.96 1995/01/05 02:15:05 jkh Exp $
#
# Please view me with 4 column tabs!
@@ -317,7 +317,7 @@ pre-install:
.endif
.if !target(install)
-install: ${INSTALL_COOKIE}
+install: build ${INSTALL_COOKIE}
${INSTALL_COOKIE}:
@echo "===> Installing for ${DISTNAME}"
@@ -376,7 +376,7 @@ pre-build:
.endif
.if !target(build)
-build: depends configure ${BUILD_COOKIE}
+build: configure ${BUILD_COOKIE}
${BUILD_COOKIE}:
@echo "===> Building for ${DISTNAME}"
@@ -402,7 +402,7 @@ pre-patch:
.endif
.if !target(patch)
-patch: ${PATCH_COOKIE}
+patch: extract ${PATCH_COOKIE}
${PATCH_COOKIE}:
@${MAKE} ${.MAKEFLAGS} pre-patch
@@ -432,7 +432,7 @@ pre-configure:
.endif
.if !target(configure)
-configure: extract patch ${CONFIGURE_COOKIE}
+configure: depends patch ${CONFIGURE_COOKIE}
${CONFIGURE_COOKIE}:
@echo "===> Configuring for ${DISTNAME}"