aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-08-18 18:53:16 +0800
committerasami <asami@FreeBSD.org>1996-08-18 18:53:16 +0800
commitfcf27c10e91a5b6b8a222fb80256abafe3ada703 (patch)
tree9785d18643c0aa85aa87d2c627dcea877da43e35 /Mk
parentf22a73dcbe075def350d0cf93cc0a585138530a9 (diff)
downloadfreebsd-ports-gnome-fcf27c10e91a5b6b8a222fb80256abafe3ada703.tar.gz
freebsd-ports-gnome-fcf27c10e91a5b6b8a222fb80256abafe3ada703.tar.zst
freebsd-ports-gnome-fcf27c10e91a5b6b8a222fb80256abafe3ada703.zip
(1) Use INSTALL_PROGRAM where we attempt to pass this command line
to configure. (2) Gently warn user for non-0022 umasks. Submitted by: "David E. O'Brien" <obrien@Nuxi.cs.ucdavis.edu> (1)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 387d0a5ed819..4d34663b90af 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.219 1996/08/15 05:55:33 asami Exp $
+# $Id: bsd.port.mk,v 1.220 1996/08/17 10:16:02 asami Exp $
#
# Please view me with 4 column tabs!
@@ -705,7 +705,7 @@ do-configure:
.if defined(HAS_CONFIGURE)
@(cd ${WRKSRC} && CC="${CC}" ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS}" \
INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
- INSTALL_PROGRAM="/usr/bin/install ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
.endif
.if defined(USE_IMAKE)
@@ -728,6 +728,11 @@ do-build:
.if !target(do-install)
do-install:
+ @if [ `/bin/sh -c umask` != 0022 ]; then \
+ ${ECHO_MSG} "===> Warning: your umask is \"`/bin/sh -c umask`"\".; \
+ ${ECHO_MSG} " If this is not desired, set it to an appropriate value"; \
+ ${ECHO_MSG} " and install this port again by \`\`make reinstall''."; \
+ fi
.if defined(USE_GMAKE)
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
.if defined(USE_IMAKE) && !defined(NO_INSTALL_MANPAGES)