aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /Mk
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.kde4.mk58
1 files changed, 40 insertions, 18 deletions
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index d50580971f83..f39160438e8a 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -27,6 +27,7 @@ Kde_Pre_Include= bsd.kde4.mk
# Available KDE4 components are:
#
# baseapps - Basic applications for KDE Desktop
+# kactivities - KDE activities library
# kate - KDE text editor framework
# kdehier - Hierarchy of common KDE directories
# kdelibs - KDE Developer Platform
@@ -37,12 +38,15 @@ Kde_Pre_Include= bsd.kde4.mk
# libkcompactdisc - KDE library for interfacing with audio CDs
# libkdcraw - KDE LibRaw library
# libkdeedu - Libraries used by KDE educational applications
+# libkdegames - Libraries used by KDE games
# libkexiv2 - KDE Exiv2 library
# libkipi - KDE Image Plugin Interface
# libkonq - Konqueror core library
# libksane - KDE SANE library
# marble - KDE virtual globe
# okular - KDE universal document viewer
+# nepomuk-core - Nepomuk core libraries
+# nepomuk-widgets - Nepomuk widgets library
# oxygen - KDE icon theme
# perlkde - KDE Perl bindings
# perlqt - Qt 4 Perl bindings
@@ -66,16 +70,11 @@ Kde_Pre_Include= bsd.kde4.mk
#
# These read-only variables can be used in a port's Makefile:
#
-# MASTER_SITE_KDE_kde
-# - It is equivalent to ${MASTER_SITE_KDE} with :kde tag. It could
-# be used when port needs multiple distfiles from different
-# sites. See for details the Porter's Handbook:
-# http://www.FreeBSD.org/doc/en_US.ISO8859-1/books/porters-handbook/makefile-distfiles.html
# KDE4_PREFIX - The place where KDE4 ports live. Currently it is
# ${LOCALBASE}/kde4, but this could change in the future.
#
-KDE4_VERSION?= 4.9.5
+KDE4_VERSION?= 4.10.1
KDE4_BRANCH?= stable
CALLIGRA_VERSION?= 2.5.5
CALLIGRA_BRANCH?= stable
@@ -88,9 +87,8 @@ KDEVELOP_BRANCH?= stable
KDE4_PREFIX?= ${LOCALBASE}/kde4
-#
-# Common definitions for KDE4 ports.
-#
+# Help cmake to find files when testing ports with non-default PREFIX
+CMAKE_ARGS+= -DCMAKE_PREFIX_PATH="${LOCALBASE};${KDE4_PREFIX}"
# ${PREFIX} and ${NO_MTREE} have to be defined in the pre-makefile section.
.if defined(USE_KDE4) && ${USE_KDE4:Mkdeprefix} != ""
@@ -129,11 +127,13 @@ Kde_Post_Include= bsd.kde4.mk
# for ${component}; otherwise, it will default to 'build run'.
#
-_USE_KDE4_ALL= baseapps kate kdehier kdelibs kdeprefix korundum libkcddb \
- libkcompactdisc libkdcraw libkdeedu libkexiv2 libkipi \
- libkonq libksane marble okular oxygen perlkde perlqt \
- pimlibs pykde4 pykdeuic4 qtruby runtime sharedmime \
- smokegen smokekde smokeqt workspace
+_USE_KDE4_ALL= baseapps kactivities kate kdehier kdelibs kdeprefix \
+ korundum libkcddb libkcompactdisc libkdcraw libkdeedu \
+ libkexiv2 libkdegames libkipi libkonq libksane marble \
+ nepomuk-core nepomuk-widgets \
+ okular oxygen perlkde perlqt pimlibs pykde4 pykdeuic4 \
+ qtruby runtime sharedmime smokegen smokekde smokeqt \
+ workspace
# These components are not part of the Software Compilation.
_USE_KDE4_ALL+= akonadi attica automoc4 ontologies qimageblitz soprano \
strigi
@@ -142,6 +142,9 @@ baseapps_PORT= x11/kde4-baseapps
baseapps_PATH= ${KDE4_PREFIX}/bin/kfmclient
baseapps_TYPE= run
+kactivities_PORT= x11/kactivities
+kactivities_PATH= ${KDE4_PREFIX}/lib/libkactivities.so.6
+
kate_PORT= editors/kate
kate_PATH= ${KDE4_PREFIX}/lib/libkateinterfaces.so.5
@@ -163,16 +166,19 @@ libkcompactdisc_PORT= audio/libkcompactdisc
libkcompactdisc_PATH= ${KDE4_PREFIX}/lib/libkcompactdisc.so.5
libkdcraw_PORT= graphics/libkdcraw-kde4
-libkdcraw_PATH= ${KDE4_PREFIX}/lib/libkdcraw.so.21
+libkdcraw_PATH= ${KDE4_PREFIX}/lib/libkdcraw.so.22
libkdeedu_PORT= misc/libkdeedu
libkdeedu_PATH= ${KDE4_PREFIX}/lib/libkeduvocdocument.so.5
+libkdegames_PORT= games/libkdegames
+libkdegames_PATH= ${KDE4_PREFIX}/lib/libkdegames.so.6
+
libkexiv2_PORT= graphics/libkexiv2-kde4
libkexiv2_PATH= ${KDE4_PREFIX}/lib/libkexiv2.so.11
libkipi_PORT= graphics/libkipi-kde4
-libkipi_PATH= ${KDE4_PREFIX}/lib/libkipi.so.9
+libkipi_PATH= ${KDE4_PREFIX}/lib/libkipi.so.10
libkonq_PORT= x11/libkonq
libkonq_PATH= ${KDE4_PREFIX}/lib/libkonq.so.7
@@ -181,10 +187,16 @@ libksane_PORT= graphics/libksane
libksane_PATH= ${KDE4_PREFIX}/lib/libksane.so.0
marble_PORT= astro/marble
-marble_PATH= ${KDE4_PREFIX}/lib/libmarblewidget.so.14
+marble_PATH= ${KDE4_PREFIX}/lib/libmarblewidget.so.15
+
+nepomuk-core_PORT= sysutils/nepomuk-core
+nepomuk-core_PATH= ${KDE4_PREFIX}/lib/libnepomukcore.so.5
+
+nepomuk-widgets_PORT= sysutils/nepomuk-widgets
+nepomuk-widgets_PATH= ${KDE4_PREFIX}/lib/libnepomukwidgets.so.5
okular_PORT= graphics/okular
-okular_PATH= ${KDE4_PREFIX}/lib/libokularcore.so.1
+okular_PATH= ${KDE4_PREFIX}/lib/libokularcore.so.2
oxygen_PORT= x11-themes/kde4-icons-oxygen
oxygen_PATH= ${KDE4_PREFIX}/share/icons/oxygen/index.theme
@@ -286,4 +298,14 @@ IGNORE= can't be installed: unknown USE_KDE4 component '${component}'
. endif # ${_USE_KDE4_ALL:M${component}} != ""
.endfor
+.if defined(USE_KDE4) && ${USE_KDE4:Msharedmime} != ""
+post-install: post-install-sharedmime
+. if !target(post-install-sharedmime)
+post-install-sharedmime:
+ @-${LOCALBASE}/bin/update-mime-database ${KDE4_PREFIX}/share/mime
+ @${ECHO_CMD} "@exec ${LOCALBASE}/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${LOCALBASE}/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true" >> ${TMPPLIST}
+. endif
+.endif
+
.endif # defined(_POSTMKINCLUDED) && !defined(Kde_Post_Include)