aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-04-27 20:14:29 +0800
committermat <mat@FreeBSD.org>2017-04-27 20:14:29 +0800
commit8fe943f30c5624108625a00842bd7f2e18228ba2 (patch)
tree103494191e0082dcb4164e3caa6cd9f4668fb036 /Mk
parentae22ab7f74c4cc5a4e1bf6678d0bca3b7344e696 (diff)
downloadfreebsd-ports-gnome-8fe943f30c5624108625a00842bd7f2e18228ba2.tar.gz
freebsd-ports-gnome-8fe943f30c5624108625a00842bd7f2e18228ba2.tar.zst
freebsd-ports-gnome-8fe943f30c5624108625a00842bd7f2e18228ba2.zip
Enhance the BROKEN_SSL messages.
Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ssl.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index 0162859348bd..653e1222b301 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -79,9 +79,9 @@ OPENSSL_PORT= security/${SSL_DEFAULT}
. if defined(BROKEN_SSL) && ${BROKEN_SSL:M${SSL_DEFAULT}}
. if defined(BROKEN_SSL_REASON_${SSL_DEFAULT})
-BROKEN= ${BROKEN_SSL_REASON_${SSL_DEFAULT}}
+BROKEN= does not build with DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT}: ${BROKEN_SSL_REASON_${SSL_DEFAULT}}
. elif defined(BROKEN_SSL_REASON)
-BROKEN= ${BROKEN_SSL_REASON}
+BROKEN= does not build with DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT}: ${BROKEN_SSL_REASON}
. else
BROKEN= does not build with DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT}
. endif
@@ -89,9 +89,9 @@ BROKEN= does not build with DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT}
. if defined(IGNORE_SSL) && ${IGNORE_SSL:M${SSL_DEFAULT}}
. if defined(IGNORE_SSL_REASON_${SSL_DEFAULT})
-IGNORE= ${IGNORE_SSL_REASON_${SSL_DEFAULT}}
+IGNORE= not compatible DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT}: ${IGNORE_SSL_REASON_${SSL_DEFAULT}}
. elif defined(IGNORE_SSL_REASON)
-IGNORE= ${IGNORE_SSL_REASON}
+IGNORE= not compatible DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT}: ${IGNORE_SSL_REASON}
. else
IGNORE= not compatible DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT}
. endif