aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-29 02:47:25 +0800
committertobik <tobik@FreeBSD.org>2018-09-29 02:47:25 +0800
commite97e9f4620d7a5ff9578dc06d33e1012996722a3 (patch)
treee25ea16d97be0570a2eccb78787962b611f5b9cf /Mk
parent2080b755ce5536439a9cc6c50c9408ac12e5bc7f (diff)
downloadfreebsd-ports-gnome-e97e9f4620d7a5ff9578dc06d33e1012996722a3.tar.gz
freebsd-ports-gnome-e97e9f4620d7a5ff9578dc06d33e1012996722a3.tar.zst
freebsd-ports-gnome-e97e9f4620d7a5ff9578dc06d33e1012996722a3.zip
Bump minimum Rust version in Mk/Uses/cargo.mk
Given that at least ripgrep will soon require Rust >= 1.28.0 [1] and given the recently discovered buffer overflow vulnerability in the standard library of Rust < 1.29.1 [2] bump it to 1.29.1 to avoid surprises. [1] https://github.com/BurntSushi/ripgrep/issues/1019 [2] https://groups.google.com/forum/#!topic/rustlang-security-announcements/CmSuTm-SaU0
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 7590170a069b..6c2514d5367e 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -46,7 +46,7 @@ DISTFILES+= ${CARGO_DIST_SUBDIR}/${_crate}.tar.gz:cargo_${_crate:S/-//g:S/.//g}
CARGO_BUILDDEP?= yes
.if ${CARGO_BUILDDEP:tl} == "yes"
-BUILD_DEPENDS+= rust>=1.19.0_2:lang/rust
+BUILD_DEPENDS+= rust>=1.29.1:lang/rust
.endif
# Location of cargo binary (default to lang/rust's Cargo binary)