aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2008-08-15 20:29:42 +0800
committerbsam <bsam@FreeBSD.org>2008-08-15 20:29:42 +0800
commit00bd2155ed3622a789ce4448c3b7e65270933d7b (patch)
treef46739bb361d8af8fadbdcc098fba204e4285d7d /Mk
parent4ab8e99ab21c1b4a56718aad1f851970dad96fd6 (diff)
downloadfreebsd-ports-gnome-00bd2155ed3622a789ce4448c3b7e65270933d7b.tar.gz
freebsd-ports-gnome-00bd2155ed3622a789ce4448c3b7e65270933d7b.tar.zst
freebsd-ports-gnome-00bd2155ed3622a789ce4448c3b7e65270933d7b.zip
Make bsd.linux-rpm.mk respect NOPORTDOCS variable.
PR: 123964 Submitted by: Ganael Laplanche <ganael.laplanche at martymac.com> Discussed at: emulation@
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.linux-rpm.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index 658841da7a9c..f7aac003d566 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -1,7 +1,7 @@
#-*- mode: Makefile; tab-width: 4; -*-
# ex:ts=4
#
-# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.12 2008-04-29 19:20:52 bsam Exp $
+# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.13 2008-08-15 12:29:42 bsam Exp $
#
# Variables:
@@ -105,6 +105,20 @@ MD5_FILE?= ${MASTERDIR}/distinfo.${LINUX_RPM_ARCH}
BRANDELF_DIRS?=
BRANDELF_FILES?=
+# For ports that define PORTDOCS, be sure not to install
+# documentation if NOPORTDOCS is defined
+. if defined(PORTDOCS) && defined(NOPORTDOCS)
+pre-patch: linux-rpm-clean-portdocs
+
+. if !target(linux-rpm-clean-portdocs)
+linux-rpm-clean-portdocs:
+. for x in ${PORTDOCS}
+ @${RM} -f ${WRKDIR}/${DOCSDIR_REL}/${x}
+. endfor
+ @${RMDIR} ${WRKDIR}/${DOCSDIR_REL}
+. endif
+. endif
+
. if defined(AUTOMATIC_PLIST)
. if ${USE_LINUX} == "fc4" || ${USE_LINUX:L} == "yes"