aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-02-16 22:41:43 +0800
committerkoobs <koobs@FreeBSD.org>2014-02-16 22:41:43 +0800
commit1639dec579b27c190ddc07ee6a9cf7633071a9c4 (patch)
tree764c1dd2a64e2d8d115679e36c884564e6eaa240 /Mk
parent873007254505b0d43612de7b6ae304ab7650c363 (diff)
downloadfreebsd-ports-gnome-1639dec579b27c190ddc07ee6a9cf7633071a9c4.tar.gz
freebsd-ports-gnome-1639dec579b27c190ddc07ee6a9cf7633071a9c4.tar.zst
freebsd-ports-gnome-1639dec579b27c190ddc07ee6a9cf7633071a9c4.zip
Any python package that uses console_scripts in setup.py needs the
pkg_resources module from setuptools at run time. This generally means anything that installs a CLI utility. Package-only users do not get setuptools installed when they install the packages of these ports currently, because USE_PYDISTUTILS=yes doesnt set a RUN_DEPENDS on it. This breaks console script invocation, with the following error: Traceback (most recent call last): File "/usr/local/bin/<script-name>", line 5, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources The FreeBSD Python team has recently standardised on a consistent installation pattern for all python software, whether pure-distutils or setuptools based, and this run-time requirement is currently not being satisfied, breaking ports that use that functionality. This commit moves RUN_DEPENDS+=setuptools from the =easy_install *only* case, to the default case. This does mean that py27-setuptools and py33-setuptools cannot be installed concurrently, precluding dual stack Python installations. The FreeBSD Python team is working hard towards a future where multiple python and packages versions *can* be installed concurrently, but it is not explicitly supported in the current state. Improvements to FreeBSD's ports and package frameworks will help achieve that goal. [1] http://lists.freebsd.org/pipermail/freebsd-python/2014-February/006592.html [2] http://lists.freebsd.org/pipermail/freebsd-python/2014-February/006609.html PR: ports/186706 Reported by: Scott Sturdivant <scott dot sturdivant at gmail.com> Reviewed by: antoine, rm, mva MFH: 2014Q1
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 43162bc21a7c..a8ebb326e54b 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -414,11 +414,11 @@ PYTHONPREFIX_SITELIBDIR= ${PYTHON_SITELIBDIR:S;${PYTHONBASE};${PREFIX};}
_CURRENTPORT:= ${PKGNAMEPREFIX}${PORTNAME}
.if defined(USE_PYDISTUTILS) && ${_CURRENTPORT} != ${PYTHON_PKGNAMEPREFIX}setuptools
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:${PORTSDIR}/devel/py-setuptools
.endif
# setuptools support
.if defined(USE_PYDISTUTILS) && ${USE_PYDISTUTILS} == "easy_install"
-RUN_DEPENDS+= ${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
PYDISTUTILS_BUILD_TARGET?= bdist_egg
PYDISTUTILS_INSTALL_TARGET?= easy_install