aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-18 22:12:04 +0800
committerpav <pav@FreeBSD.org>2006-03-18 22:12:04 +0800
commit22591001a4d5bb569246b36ab1e308b71e6827e2 (patch)
tree48f6be0284bf9a701957cff06d2ae90aa98990eb /Mk
parent8438ebe81b80af9eae92f6d3e66a64fe3742d207 (diff)
downloadfreebsd-ports-gnome-22591001a4d5bb569246b36ab1e308b71e6827e2.tar.gz
freebsd-ports-gnome-22591001a4d5bb569246b36ab1e308b71e6827e2.tar.zst
freebsd-ports-gnome-22591001a4d5bb569246b36ab1e308b71e6827e2.zip
- Add PDO extension to a php5-extensions metaport and enable it by default.
This is consistent with vendor configure. PR: ports/90565 Submitted by: Alexander Zhuravlev <zaa@zaa.pp.ru> Approved by: maintainer timeout (ale; 3 months)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.php.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 6793f13c4b67..56ae71d16f90 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -261,7 +261,7 @@ _USE_PHP_ALL= bcmath bz2 calendar ctype curl dba dbase \
# version specific components
_USE_PHP_VER4= ${_USE_PHP_ALL} crack dbx dio domxml mcal mcve \
mnogosearch oracle overload pfpro xslt yp
-_USE_PHP_VER5= ${_USE_PHP_ALL} dom mysqli simplexml soap sqlite \
+_USE_PHP_VER5= ${_USE_PHP_ALL} dom mysqli pdo simplexml soap sqlite \
tidy xmlreader xmlwriter xsl
bcmath_DEPENDS= math/php${PHP_VER}-bcmath
@@ -308,6 +308,7 @@ panda_DEPENDS= print/pecl-panda
pcntl_DEPENDS= devel/php${PHP_VER}-pcntl
pcre_DEPENDS= devel/php${PHP_VER}-pcre
pdf_DEPENDS= print/pecl-pdflib
+pdo_DEPENDS= databases/pecl-PDO
pfpro_DEPENDS= finance/php${PHP_VER}-pfpro
pgsql_DEPENDS= databases/php${PHP_VER}-pgsql
posix_DEPENDS= sysutils/php${PHP_VER}-posix