aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-10-23 07:02:39 +0800
committerjkh <jkh@FreeBSD.org>1994-10-23 07:02:39 +0800
commit75c41d2676f55ff2dcb8b2a1cf151314dbf93e00 (patch)
treed280198a1c0a45201872930dad67de28ee5fd92b /Mk
parentea5a6d0f74a76426c883de421bd15e686cabeb54 (diff)
downloadfreebsd-ports-gnome-75c41d2676f55ff2dcb8b2a1cf151314dbf93e00.tar.gz
freebsd-ports-gnome-75c41d2676f55ff2dcb8b2a1cf151314dbf93e00.tar.zst
freebsd-ports-gnome-75c41d2676f55ff2dcb8b2a1cf151314dbf93e00.zip
1. PREFIX has nothing to do with DESTDIR. Remove it finally.
2. Make sure to pass PREFIX to sub-makes when installing. This allows you to install to places like ${PREFIX}/bin in your own install rule.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 808539af945f..59538617a942 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.57 1994/10/14 21:58:09 ache Exp $
+# $Id: bsd.port.mk,v 1.58 1994/10/22 09:21:35 jkh Exp $
#
# Please view me with 4 column tabs!
@@ -87,7 +87,7 @@
# tree we are and thus can't go relative. They can, of course, be overridden
# by individual Makefiles.
PORTSDIR?= ${DESTDIR}/usr/ports
-PREFIX?= ${DESTDIR}/usr/local
+PREFIX?= /usr/local
DISTDIR?= ${PORTSDIR}/distfiles
PACKAGES?= ${PORTSDIR}/packages
WRKDIR?= ${.CURDIR}/work
@@ -233,9 +233,9 @@ ${INSTALL_COOKIE}:
@echo "===> Installing for ${DISTNAME}"
@${MAKE} ${.MAKEFLAGS} pre-install
.if defined(USE_GMAKE)
- @(cd ${WRKSRC}; ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} install)
+ @(cd ${WRKSRC}; ${GMAKE} PREFIX=${PREFIX} ${MAKE_FLAGS} ${MAKEFILE} install)
.else defined(USE_GMAKE)
- @(cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install)
+ @(cd ${WRKSRC}; ${MAKE} PREFIX=${PREFIX} ${MAKE_FLAGS} ${MAKEFILE} install)
.if defined(USE_IMAKE)
@(cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install.man)
.endif