aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-03-20 09:12:20 +0800
committerbapt <bapt@FreeBSD.org>2015-03-20 09:12:20 +0800
commit915b957824abf855e57741351fa39833385a09b6 (patch)
tree6c84536921c7c5a3def1d614c13a8a70d850700c /Mk
parent075cd1473ac5e82af7dffe1b74c945c5ad9f6850 (diff)
downloadfreebsd-ports-gnome-915b957824abf855e57741351fa39833385a09b6.tar.gz
freebsd-ports-gnome-915b957824abf855e57741351fa39833385a09b6.tar.zst
freebsd-ports-gnome-915b957824abf855e57741351fa39833385a09b6.zip
Rework XORG_CAT= font
Fonts are now generating the fonts.scale and fonts.dir at install time font-alias is not needed anymore for the above reason extract font-util and encodings out of XORG_CAT=fonts because they do not install any fonts make XORG_CAT=fonts use USES=fonts
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/display.mk1
-rw-r--r--Mk/bsd.xorg.mk46
2 files changed, 4 insertions, 43 deletions
diff --git a/Mk/Uses/display.mk b/Mk/Uses/display.mk
index 5b5c8b533559..200b58b26703 100644
--- a/Mk/Uses/display.mk
+++ b/Mk/Uses/display.mk
@@ -18,7 +18,6 @@ display_ARGS= install
.if !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/xorg-vfbserver \
${LOCALBASE}/lib/X11/fonts/misc/8x13O.pcf.gz:${PORTSDIR}/x11-fonts/xorg-fonts-miscbitmaps \
- ${LOCALBASE}/lib/X11/fonts/misc/fonts.alias:${PORTSDIR}/x11-fonts/font-alias \
${LOCALBASE}/share/X11/xkb/rules/base:${PORTSDIR}/x11/xkeyboard-config \
xkbcomp:${PORTSDIR}/x11/xkbcomp
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index 941505d3f50e..72427c95bb3c 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -69,50 +69,12 @@ USES+= libtool
. endif
. if ${XORG_CAT} == "font"
-FONTDIR?= ${PORTNAME:C/.*-//g:S/type/Type/:S/ttf/TTF/:S/speedo/Speedo/}
+FONTNAME?= ${PORTNAME:C/.*-//g:S/type/Type/:S/ttf/TTF/:S/speedo/Speedo/}
CONFIGURE_ARGS+= --with-fontrootdir=${PREFIX}/lib/X11/fonts
CONFIGURE_ENV+= FONTROOTDIR=${PREFIX}/lib/X11/fonts
-NEED_MKFONTFOO= yes
-
-. if ${PORTNAME:M*type1*}x != x
-INSTALLS_TTF?= yes
-. elif ${PORTNAME:M*ttf*}x != x
-INSTALLS_TTF?= yes
-. elif ${PORTNAME:M*encodings*}x != x
-# This is terrific, we want mkfontscale at build time, but don't use it like for the other ports.
-NEED_MKFONTFOO= no
-BUILD_DEPENDS+= ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-INSTALLS_TTF?= no
-. else
-INSTALLS_TTF?= no
-. endif
-
-. if ${PORTNAME:M*font-util*}x != x
-USES+= pathfix
-NEED_MKFONTFOO= no
-. elif ${INSTALLS_TTF} == "yes"
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig
-. else
-BUILD_DEPENDS+= ${LOCALBASE}/bin/bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
-. endif
-
-. if ${NEED_MKFONTFOO} == "yes"
-BUILD_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-RUN_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-. endif
-
-. for _fontdir in ${FONTDIR}
-. if ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == yes
-PLIST_FILES+= "@fcfontsdir ${PREFIX}/lib/X11/fonts/${_fontdir}"
-. elif ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == no
-PLIST_FILES+= "@fc ${PREFIX}/lib/X11/fonts/${_fontdir}"
-. elif ${NEED_MKFONTFOO} == yes
-PLIST_FILES+= "@fontsdir ${PREFIX}/lib/X11/fonts/${_fontdir}"
-. endif
-. endfor
+USES+= fonts
+BUILD_DEPENDS+= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
.endif
. if ${XORG_CAT} == "lib"