aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-02-04 22:23:08 +0800
committerbapt <bapt@FreeBSD.org>2014-02-04 22:23:08 +0800
commitb269333cd44643fc22899836634e09ac0bc723e6 (patch)
tree9af38bb454b66be192b9853b24e82fdb3b3c6c35 /Mk
parentb51d92247b09e6fab0b576031f75ade4adf6306b (diff)
downloadfreebsd-ports-gnome-b269333cd44643fc22899836634e09ac0bc723e6.tar.gz
freebsd-ports-gnome-b269333cd44643fc22899836634e09ac0bc723e6.tar.zst
freebsd-ports-gnome-b269333cd44643fc22899836634e09ac0bc723e6.zip
Add a user warning so that everyone get a notice about the upcoming EoL of pkg_install
Add a end user NO_WARNING_PKG_INSTALL_EOL to allow users willing to stay a bit more with pkg_install to not get bothered all the time with the warning With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a937c25cda5c..dcdac836f75c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1206,6 +1206,12 @@ WITH_PKGNG?= yes
.endif
.endif
+.if !defined(WITH_PKGNG) && !defined(NO_WARNING_PKG_INSTALL_EOL)
+WARNING+= "pkg_install EOL is scheduled for 2014-09-01. Please consider migrating to pkgng"
+WARNING+= "http://blogs.freebsdish.org/portmgr/2014/02/03/time-to-bid-farewell-to-the-old-pkg_-tools/"
+WARNING+= "If you do not want to see this message again set NO_WARNING_PKG_INSTALL_EOL=yes in your make.conf"
+.endif
+
# Enable new xorg for FreeBSD versions after Radeon KMS was imported unless
# WITHOUT_NEW_XORG is set.
.if ${OSVERSION} >= 1100000
@@ -4169,6 +4175,10 @@ fix-plist-sequence: ${TMPPLIST}
@${EGREP} -v -e '^@exec echo.*Creating users and' -e '^@exec.*${PW}' -e '^@exec ${INSTALL} -d -g' ${TMPPLIST} >> ${TMPGUCMD}
@${MV} -f ${TMPGUCMD} ${TMPPLIST}
.endif
+.if !defined(WITH_PKGNG)
+ @${ECHO_CMD} "@exec echo pkg_install EOL is scheduled for 2014-09-01. Please consider migrating to pkgng" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec echo http://blogs.freebsdish.org/portmgr/2014/02/03/time-to-bid-farewell-to-the-old-pkg_-tools/" >> ${TMPPLIST}
+.endif
.endif
.if !defined(DISABLE_SECURITY_CHECK)