aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-12-20 01:06:16 +0800
committerperky <perky@FreeBSD.org>2004-12-20 01:06:16 +0800
commitce1b83962406295ecb93a159a6c725ee18389b89 (patch)
treebc1e53baa4aec8abb19ec55e9408a9af379a3887 /Mk
parentc48d5c9a9690488aa0168410b2699d9798e360c1 (diff)
downloadfreebsd-ports-gnome-ce1b83962406295ecb93a159a6c725ee18389b89.tar.gz
freebsd-ports-gnome-ce1b83962406295ecb93a159a6c725ee18389b89.tar.zst
freebsd-ports-gnome-ce1b83962406295ecb93a159a6c725ee18389b89.zip
Force to use Python 2.3 for Zope ports. We still have "duplicated
ORIGIN" problem when a python extension module is needed by not only a Zope product but also non-Zope python application. And there's no known good solution yet. PR: 75013 Submitted by: Filippo Natali <filippo@widestore.net>
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 2e5843e42266..d1cfe1c70c68 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -119,6 +119,10 @@ Python_Include_MAINTAINER= perky@FreeBSD.org
_PYTHON_PORTBRANCH= 2.4
_PYTHON_ALLBRANCHES= 2.4 2.3 2.2 2.1 # preferred first
+.if defined(USE_ZOPE)
+PYTHON_VERSION= python2.3
+.endif
+
.if defined(PYTHON_VERSION)
_PYTHON_VERSION!= ${ECHO_CMD} "${PYTHON_VERSION}" | ${SED} 's/^python//'
_PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_VERSION}