aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-10-28 21:08:14 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-10-28 21:08:14 +0800
commite4866fdf82d0ed9108197a5539d7b98091f28aec (patch)
treeccb076651b2616673f83c9fd46fa386225b72ab5 /Mk
parentfe7add8d9ede57f227c197d299201b2b60db8e2f (diff)
downloadfreebsd-ports-gnome-e4866fdf82d0ed9108197a5539d7b98091f28aec.tar.gz
freebsd-ports-gnome-e4866fdf82d0ed9108197a5539d7b98091f28aec.tar.zst
freebsd-ports-gnome-e4866fdf82d0ed9108197a5539d7b98091f28aec.zip
- Fix COPYTREE_BIN and COPYTREE_SHARE so that installed symlinks
have proper permissions set. PR: ports/173892 Submitted by: thierry With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 5d78cf61e7c2..302cf0f4e2f0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2334,12 +2334,12 @@ SCRIPTS_ENV+= ${INSTALL_MACROS}
.if ${UID} == 0
COPYTREE_BIN= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
2>&1) && \
- ${CHOWN} -R ${BINOWN}:${BINGRP} $$1 && \
+ ${CHOWN} -Rh ${BINOWN}:${BINGRP} $$1 && \
${FIND} -d $$0 $$2 -type d -exec chmod 755 $$1/{} \; && \
${FIND} -d $$0 $$2 -type f -exec chmod ${BINMODE} $$1/{} \;' --
COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
+ ${CHOWN} -Rh ${SHAREOWN}:${SHAREGRP} $$1 && \
${FIND} -d $$0 $$2 -type d -exec chmod 755 $$1/{} \; && \
${FIND} -d $$0 $$2 -type f -exec chmod ${SHAREMODE} $$1/{} \;' --
.else