aboutsummaryrefslogtreecommitdiffstats
path: root/Tools/scripts
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-11-02 17:20:10 +0800
committervd <vd@FreeBSD.org>2006-11-02 17:20:10 +0800
commitcb7f964b745f540672f26fb060006640743a4ea2 (patch)
tree470a74d0c8478b49f7a14e3e78e64580d94359b6 /Tools/scripts
parent807f08ea77d467126a8227050aea33e8b9764ea9 (diff)
downloadfreebsd-ports-gnome-cb7f964b745f540672f26fb060006640743a4ea2.tar.gz
freebsd-ports-gnome-cb7f964b745f540672f26fb060006640743a4ea2.tar.zst
freebsd-ports-gnome-cb7f964b745f540672f26fb060006640743a4ea2.zip
Add deprecated reason to the output of -F
Diffstat (limited to 'Tools/scripts')
-rwxr-xr-xTools/scripts/rmport8
1 files changed, 6 insertions, 2 deletions
diff --git a/Tools/scripts/rmport b/Tools/scripts/rmport
index 680e46dc2f4f..8f9961e1893d 100755
--- a/Tools/scripts/rmport
+++ b/Tools/scripts/rmport
@@ -92,7 +92,11 @@ find_expired()
find ${PORTSDIR} -mindepth 3 -maxdepth 3 -name "Makefile*" \
|xargs grep -H ${EXPVAR} \
|sed -E "s|${PORTSDIR}/?([^/]+/[^/]+)/Makefile:${EXPVAR}=[[:space:]]*([0-9-]{10})$|\2 \1|g" \
- |perl -ne "if ((substr(\$_, 0, 10) cmp '${TODAY}') <= 0) { print(\$_); }"
+ |perl -ne "if ((substr(\$_, 0, 10) cmp '${TODAY}') <= 0) { print(\$_); }" \
+ |while read expdate catport ; do \
+ echo -n "${expdate} ${catport}: " ; \
+ make -C ${PORTSDIR}/${catport} -V DEPRECATED ; \
+ done
}
# create temporary checkout directory
@@ -380,7 +384,7 @@ if [ ${1} = "-a" ] ; then
if [ ${#} -ne 1 ] ; then
usage
fi
- ${0} `find_expired |cut -f 2 -d ' '`
+ ${0} `find_expired |cut -f 2 -d ' ' |cut -f 1 -d :`
exit
fi