aboutsummaryrefslogtreecommitdiffstats
path: root/Tools
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-04-28 14:20:23 +0800
committerasami <asami@FreeBSD.org>1999-04-28 14:20:23 +0800
commit2a64c6c85ec242c8792cfa4ef6e11935aec3a6a7 (patch)
treee9f75c180900bf0c9a84a91c6ae92e6a24ef9320 /Tools
parentcb9e6ed1096a252299cce0d50997f889e2ec5380 (diff)
downloadfreebsd-ports-gnome-2a64c6c85ec242c8792cfa4ef6e11935aec3a6a7.tar.gz
freebsd-ports-gnome-2a64c6c85ec242c8792cfa4ef6e11935aec3a6a7.tar.zst
freebsd-ports-gnome-2a64c6c85ec242c8792cfa4ef6e11935aec3a6a7.zip
(1) Make it clear that only I am allowed to commit to bsd.port.mk.
(2) New variable USE_ZIP -- will change EXTRACT_SUFX to ".zip" and extract commands/arguments accordingly. Submitted by: jseger (3) Use ${GREP} in some places where grep was used. (4) A little update to the MASTER_SITES_GNU list. Submitted by: cpiazza@home.net (5) New target clean-for-cdrom-list and clean-restricted-list -- will print out commands to delete un-cdromable or unredistributable files. Save them into a shell script for later use. (6) Add CXXFLAGS="${CXXFLAGS}" to configure's environment. Submitted by: reg@shale.csir.co.za PR: 11353 (part 3/3) (7) Print out a warning if you try to install without being root. Abort if ${PREFIX} is not writable. (8) Add web site to INDEX as tenth field. Reviewed by: wosch, steve, scrappy
Diffstat (limited to 'Tools')
-rw-r--r--Tools/make_index7
1 files changed, 4 insertions, 3 deletions
diff --git a/Tools/make_index b/Tools/make_index
index 952bbd3f1b17..7465517fb55b 100644
--- a/Tools/make_index
+++ b/Tools/make_index
@@ -1,6 +1,6 @@
#!/usr/bin/perl
#
-# $Id: make_index,v 1.3 1999/03/11 21:47:09 scrappy Exp $
+# $Id: make_index,v 1.4 1999/03/13 04:25:21 scrappy Exp $
#
# Written to speed-up INDEX file generation. The new scheme
# basically visits each port once and writes out each port's
@@ -83,7 +83,8 @@ while (<>) {
my $pkg = {
'bdep' => [split(/ /, $f[7])],
'rdep' => [split(/ /, $f[8])],
- 'text' => join('|', splice(@f, 0, 7))
+ 'text' => join('|', splice(@f, 0, 7)),
+ 'rest' => join('|', splice(@f, 9))
};
$index{$name} = $pkg;
@@ -115,5 +116,5 @@ foreach $name (@names) {
print join(' ', sort(@{$pkg->{bdep}})) if @{$pkg->{bdep}};
print "|";
print join(' ', sort(@{$pkg->{rdep}})) if @{$pkg->{rdep}};
- print "\n";
+ print "|$pkg->{rest}\n";
}