aboutsummaryrefslogtreecommitdiffstats
path: root/Tools
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2008-06-11 21:22:58 +0800
committerkris <kris@FreeBSD.org>2008-06-11 21:22:58 +0800
commit4df0b563b308159607675a54efb8c0ff6de6a0ef (patch)
treef9a3438bc5cf4e32ff06a4a98f85589d478b555f /Tools
parent0e920e8e3c3ed701ea2878473cb49940dec4716b (diff)
downloadfreebsd-ports-gnome-4df0b563b308159607675a54efb8c0ff6de6a0ef.tar.gz
freebsd-ports-gnome-4df0b563b308159607675a54efb8c0ff6de6a0ef.tar.zst
freebsd-ports-gnome-4df0b563b308159607675a54efb8c0ff6de6a0ef.zip
* Catch up to X11R6 removal
* Keep RESTRICTED distfiles in a separate DISTDIR so we can easily avoid accidentally publishing them to the FTP site (idea from des@)
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/portbuild/scripts/buildscript19
1 files changed, 12 insertions, 7 deletions
diff --git a/Tools/portbuild/scripts/buildscript b/Tools/portbuild/scripts/buildscript
index 36f9453b5db5..ec05c6594347 100755
--- a/Tools/portbuild/scripts/buildscript
+++ b/Tools/portbuild/scripts/buildscript
@@ -120,9 +120,17 @@ L=`echo ${LOCALBASE} | sed 's,^/,,'`
X=`echo ${X11BASE} | sed 's,^/,,'`
Z=`ident ${dir}/Makefile | grep 'FreeBSD:' | sed 's/^[ \t]*//'`
+cd $dir || exit 1
+restr=$(make -V RESTRICTED)
+
+# Keep restricted distfiles in a subdirectory for extra protection
+# against leakage
+if [ ! -z "$restr" ]; then
+ export DISTDIR=${DISTDIR}/RESTRICTED
+fi
+
if [ $phase = 1 ]; then
- # note: if you change this header, also change processonelog and processlogs2
cd $dir || exit 1
echo "building for: $(uname -mr)"
echo "maintained by: $(make maintainer)"
@@ -160,14 +168,12 @@ if [ $phase = 1 ]; then
./usr/local/etc/apache2
./usr/local/news
./usr/local/share/xml
-./usr/X11R6/etc/gconf
./usr/local/etc/gconf
./var/db/fontconfig
EOF
# Record a "pristine" mtree.
mtree -X /tmp/mtree.preexclude -xcn -k uid,gid,mode -p / > /tmp/mtree.pristine
-
add_pkg $FD
cd $dir || exit 1
@@ -228,7 +234,6 @@ else
./usr/local/etc/apache2
./usr/local/news
./usr/local/share/xml
-./usr/X11R6/etc/gconf
./usr/local/etc/gconf
./var/db/fontconfig
EOF
@@ -254,7 +259,7 @@ EOF
cd $dir
/pnohang $TIMEOUT /tmp/make.log5 ${pkgname} make -k regression-test
cat /tmp/make.log5
- mtree -X /tmp/mtree.buildexclude -x -f /tmp/mtree.prebuild -p / | egrep -v "^(${L}/var|${X}/lib/X11/xserver/SecurityPolicy|${L}/share/nls/POSIX|${L}/share/nls/en_US.US-ASCII|etc/services|compat |${X} |etc/manpath.config|etc/.*.bak|${L}/info/dir|${X}/lib/X11/fonts/.*/fonts\.|usr/(X11R6|local)/man/..( |/man. )|${X}/lib/X11/fonts/TrueType|${X}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|${L}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|var/db/fontconfig/* )" > /tmp/list.preinstall
+ mtree -X /tmp/mtree.buildexclude -x -f /tmp/mtree.prebuild -p / | egrep -v "^(${L}/var|${X}/lib/X11/xserver/SecurityPolicy|${L}/share/nls/POSIX|${L}/share/nls/en_US.US-ASCII|etc/services|compat |usr/X11R6 |etc/manpath.config|etc/.*.bak|${L}/info/dir|${X}/lib/X11/fonts/.*/fonts\.|usr/local/man/..( |/man. )|${X}/lib/X11/fonts/TrueType|${X}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|${L}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|var/db/fontconfig/* )" > /tmp/list.preinstall
if [ -s /tmp/list.preinstall ]; then
echo "================================================================"
@@ -300,7 +305,7 @@ EOF
cleanup 7
fi
- mtree -X /tmp/mtree.exclude -x -f /tmp/mtree -p / | egrep -v "^(${L}/var|${X}/lib/X11/xserver/SecurityPolicy|${L}/share/nls/POSIX|${L}/share/nls/en_US.US-ASCII|etc/services|compat |${X} |etc/manpath.config|etc/.*.bak|${L}/info/dir|${X}/lib/X11/fonts/.*/fonts\.|usr/(X11R6|local)/man/..( |/man. )|${X}/lib/X11/fonts/TrueType|${X}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|${L}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|var/db/fontconfig/* )" > /tmp/list3
+ mtree -X /tmp/mtree.exclude -x -f /tmp/mtree -p / | egrep -v "^(${L}/var|${X}/lib/X11/xserver/SecurityPolicy|${L}/share/nls/POSIX|${L}/share/nls/en_US.US-ASCII|etc/services|compat |usr/X11R6 |etc/manpath.config|etc/.*.bak|${L}/info/dir|${X}/lib/X11/fonts/.*/fonts\.|usr/local/man/..( |/man. )|${X}/lib/X11/fonts/TrueType|${X}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|${L}/etc/gconf/gconf.xml.defaults/%gconf-tree.*.xml|var/db/fontconfig/* )" > /tmp/list3
# Compare the state of the filesystem now to before the 'make install' phase
dirty=0
@@ -354,7 +359,7 @@ EOF
fi
# Compare the state of the filesystem now to clean system (should again be clean)
- mtree -X /tmp/mtree.preexclude -x -f /tmp/mtree.pristine -p / | egrep -v "^(${L}/var|${X}/lib/X11/xserver/SecurityPolicy|${L}/share/nls/POSIX|${L}/share/nls/en_US.US-ASCII|etc/services|compat |${X} |etc/manpath.config|etc/.*.bak|${L}/info/dir|${X}/lib/X11/fonts/.*/fonts\.|usr/(X11R6|local)/man/..( |/man. )|${X}/lib/X11/fonts/TrueType )" > /tmp/list3
+ mtree -X /tmp/mtree.preexclude -x -f /tmp/mtree.pristine -p / | egrep -v "^(${L}/var|${X}/lib/X11/xserver/SecurityPolicy|${L}/share/nls/POSIX|${L}/share/nls/en_US.US-ASCII|etc/services|compat |usr/X11R6 |etc/manpath.config|etc/.*.bak|${L}/info/dir|${X}/lib/X11/fonts/.*/fonts\.|usr/local/man/..( |/man. )|${X}/lib/X11/fonts/TrueType )" > /tmp/list3
echo
echo "=== Checking filesystem state after all packages deleted"