aboutsummaryrefslogtreecommitdiffstats
path: root/Tools
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-10-09 09:37:22 +0800
committerasami <asami@FreeBSD.org>2000-10-09 09:37:22 +0800
commita390811235eb33b112f53bf64b886643151db648 (patch)
tree4f0d4c1beec7a2c2694e086a970d377c92ad40e8 /Tools
parent105dcc80682de966535877032ab1890432b7229f (diff)
downloadfreebsd-ports-gnome-a390811235eb33b112f53bf64b886643151db648.tar.gz
freebsd-ports-gnome-a390811235eb33b112f53bf64b886643151db648.tar.zst
freebsd-ports-gnome-a390811235eb33b112f53bf64b886643151db648.zip
Name change, files/md5 -> distinfo. (Only change is to message -- the
code actually detects both new and old errors.) Expand the USE_XLIB case to include Xosdefs.h.
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/portbuild/scripts/processlogs4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tools/portbuild/scripts/processlogs b/Tools/portbuild/scripts/processlogs
index e72256a84e62..dc606fd41caf 100755
--- a/Tools/portbuild/scripts/processlogs
+++ b/Tools/portbuild/scripts/processlogs
@@ -54,7 +54,7 @@ else
elif grep -q 'Checksum mismatch' $1; then
reason="checksum"; tag="checksum"
elif grep -qE '(No checksum recorded for|(Maybe|Either) .* is out of date, or)' $1; then
- reason="files/md5 update"; tag="md5"
+ reason="distinfo update"; tag="distinfo"
elif grep -qE '(configure: error:|script.*failed: here are the contents of)' $1; then
reason="configure error"; tag="configure"
elif grep -qE '(bison:.*(No such file|not found)|multiple definition of `yy)' $1; then
@@ -82,7 +82,7 @@ else
elif grep -qE "(crt0|c\+\+rt0)\.o: No such file" $1; then
reason="ELF"; tag="elf"
elif grep -q ".*\.h: No such file" $1; then
- if grep -q "X11/.*\.h: No such file" $1; then
+ if grep -qE "(X11/.*|Xosdefs)\.h: No such file" $1; then
if grep -q "XFree86-.*\.tgz" $1; then
reason="missing header"; tag="header"
else