aboutsummaryrefslogtreecommitdiffstats
path: root/Tools
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-05-20 15:19:07 +0800
committerwill <will@FreeBSD.org>2002-05-20 15:19:07 +0800
commite92cec80a0ce69743f8c16f86372f360b2929b7c (patch)
treeb62831cfe66a57766755dfe37f17a3cd8e8840b0 /Tools
parentf5b1520291896c01b62df1947a8fa5d4e10874cf (diff)
downloadfreebsd-ports-gnome-e92cec80a0ce69743f8c16f86372f360b2929b7c.tar.gz
freebsd-ports-gnome-e92cec80a0ce69743f8c16f86372f360b2929b7c.tar.zst
freebsd-ports-gnome-e92cec80a0ce69743f8c16f86372f360b2929b7c.zip
Add this makefile to help people who are performing package splits to
generate the correct environment in which to do them.
Diffstat (limited to 'Tools')
-rw-r--r--Tools/scripts/release/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/Tools/scripts/release/Makefile b/Tools/scripts/release/Makefile
new file mode 100644
index 000000000000..e899f277092f
--- /dev/null
+++ b/Tools/scripts/release/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+#
+# The purpose of this Makefile is to setup a standardized environment
+# for making package splits. Basically, for each split the organization
+# looks like this:
+#
+# src/release/scripts
+# ports/Tools/scripts/release
+# RELEASE (e.g. 4.6-RELEASE or 4.6-RC1)
+# symlinks to scripts required
+# directories used by scripts
+# config files
+#
+# The desire is to provide the scripts with the environment they
+# expect while preserving the ability to cvs update them.
+
+RELEASE?=
+SRCSCRIPTDIR?= /usr/src/release/scripts
+SRCSCRIPTS= print-cdrom-packages.sh
+PORTSCRIPTS!= echo *.pl *.sh
+FORCE?= no
+PWD!= pwd
+
+all:
+ @if [ -z "${RELEASE}" ]; then \
+ echo "Release must be specified, i.e.:"; \
+ echo " make RELEASE=4.6-RELEASE"; \
+ exit 1; \
+ fi
+ @if [ -d "${RELEASE}" -a "${FORCE}" = "no" ]; then \
+ echo "The release directory ${RELEASE} already exists."; \
+ echo "To force setup type:"; \
+ echo " make RELEASE=${RELEASE} FORCE=yes"; \
+ exit 1; \
+ fi
+ # We *could* use mkdir -p, but being explicit helps.
+ mkdir ${RELEASE}
+.for SUBDIR in disc1 disc3 gen
+ mkdir ${RELEASE}/${SUBDIR}
+.endfor
+.for SCRIPT in ${PORTSCRIPTS}
+ cd ${RELEASE} && ln -s ../${SCRIPT} .
+.endfor
+.for SRCSCRIPT in ${SRCSCRIPTS}
+ cd ${RELEASE} && ln -s ${SRCSCRIPTS}/${SRCSCRIPT} .
+ @echo "Done."
+.endfor
+ cd ${RELEASE} && ln -s ../config .