aboutsummaryrefslogtreecommitdiffstats
path: root/Tools
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2018-12-17 23:09:13 +0800
committercrees <crees@FreeBSD.org>2018-12-17 23:09:13 +0800
commit68a3bfe2637eda9763e0b6652bc10e91cc531d20 (patch)
treed6ff9cee5ca780bcca6d98e96a2d69e0c49c8e80 /Tools
parent4329a2f65808b46a15130b0555a5503445e5c1da (diff)
downloadfreebsd-ports-gnome-68a3bfe2637eda9763e0b6652bc10e91cc531d20.tar.gz
freebsd-ports-gnome-68a3bfe2637eda9763e0b6652bc10e91cc531d20.tar.zst
freebsd-ports-gnome-68a3bfe2637eda9763e0b6652bc10e91cc531d20.zip
Revert flavour support.
Submitted by: rene
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/rmport4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tools/scripts/rmport b/Tools/scripts/rmport
index 07205bcffb34..9c2c3e9dc050 100755
--- a/Tools/scripts/rmport
+++ b/Tools/scripts/rmport
@@ -3,7 +3,7 @@
# rmport - remove port(s) from the FreeBSD Ports Collection.
#
# Copyright 2006-2007 Vasil Dimov
-# Copyright 2012-2012 Chris Rees
+# Copyright 2012-2018 Chris Rees
# Copyright 2016-2018 Rene Ladan
# All rights reserved.
#
@@ -121,7 +121,7 @@ find_expired()
EXPVAR=EXPIRATION_DATE
find -H ${PORTSDIR} -mindepth 3 -maxdepth 3 -name "Makefile*" \
- |xargs grep -H "^[0-9a-zA-Z_]*${EXPVAR}" \
+ |xargs grep -H "^${EXPVAR}" \
|grep -v '^#' \
|sed -E "s|${PORTSDIR}/?([^/]+/[^/]+)/Makefile[^:]*:${EXPVAR}=[[:space:]]*([0-9-]{10})$|\2 \1|g" \
|perl -ne "if ((substr(\$_, 0, 10) cmp '${TODAY}') <= 0) { print(\$_); }" \