aboutsummaryrefslogtreecommitdiffstats
path: root/Tools
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-12-28 13:45:30 +0800
committerkris <kris@FreeBSD.org>2004-12-28 13:45:30 +0800
commite6b8fe7b7074dd0194bec5563ac4e7d1fb9134fa (patch)
treeb92bc3db089ca50a895e20cbc543530e9c36cf02 /Tools
parentc848355586327f46da2b7cd643c9825bbc2ad81a (diff)
downloadfreebsd-ports-gnome-e6b8fe7b7074dd0194bec5563ac4e7d1fb9134fa.tar.gz
freebsd-ports-gnome-e6b8fe7b7074dd0194bec5563ac4e7d1fb9134fa.tar.zst
freebsd-ports-gnome-e6b8fe7b7074dd0194bec5563ac4e7d1fb9134fa.zip
* It does in fact make sense to specify -incremental and -noindex at the
same time, assuming that the admin has already built the INDEX and INDEX.old in advance. * Adapt to new method of calculating build concurrency, by summing the value of ${maxjobs} listed in every portbuild.${machine} * Support 5-exp builds
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/portbuild/scripts/dopackages14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tools/portbuild/scripts/dopackages b/Tools/portbuild/scripts/dopackages
index 2b3776bd9ead..481376a026fe 100755
--- a/Tools/portbuild/scripts/dopackages
+++ b/Tools/portbuild/scripts/dopackages
@@ -255,16 +255,11 @@ else
skipstart=0
fi
-if [ "$incremental" = 1 -a "$noindex" = 1 ]; then
- echo "-incremental and -noindex cannot both be used"
- errorexit 1
-fi
-
# mandatory arguments
branch=$1
date=$2
-if [ "x$branch" != x4 -a "x$branch" != x4-exp -a "x$branch" != x5 -a "x$branch" != x6 ]; then
+if [ "x$branch" != x4 -a "x$branch" != x4-exp -a "x$branch" != x5 -a "x$branch" != x5-exp -a "x$branch" != x6 ]; then
usage
fi
@@ -477,7 +472,12 @@ if [ "$nobuild" = 0 ]; then
cp duds.orig duds
fi
- count=$(awk '{sum+=$2}END{print sum+NR/2}' ${pb}/${arch}/mlist | sed -e 's/\..*$//')
+ count=0
+ for i in `cat ${pb}/${arch}/mlist`; do
+ . ${pb}/${arch}/portbuild.conf
+ test -f ${pb}/${arch}/portbuild.${i} && . ${pb}/${arch}/portbuild.${i}
+ count=$((${count}+${maxjobs}))
+ done
cd ${pb}/${arch}/${branch}/packages/All
ln -sf ../../Makefile .