aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/atk/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-05-14 20:12:44 +0800
committersobomax <sobomax@FreeBSD.org>2001-05-14 20:12:44 +0800
commit949efec93a47652cce066871f8833e76c5840e0c (patch)
tree074c8dc77b5991c608475965934f63313760004b /accessibility/atk/Makefile
parent4e5a5f8774b0ddeb10012b3841c8e11e900904c0 (diff)
downloadfreebsd-ports-gnome-949efec93a47652cce066871f8833e76c5840e0c.tar.gz
freebsd-ports-gnome-949efec93a47652cce066871f8833e76c5840e0c.tar.zst
freebsd-ports-gnome-949efec93a47652cce066871f8833e76c5840e0c.zip
Add atk 0.1, a GNOME accessibility toolkit (ATK).
Diffstat (limited to 'accessibility/atk/Makefile')
-rw-r--r--accessibility/atk/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/accessibility/atk/Makefile b/accessibility/atk/Makefile
new file mode 100644
index 000000000000..3162b7a56cf9
--- /dev/null
+++ b/accessibility/atk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: atk
+# Date Created: 14 May 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= atk
+PORTVERSION= 0.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
+ ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
+ http://www.ameth.org/gimp/%SUBDIR%/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
+MASTER_SITE_SUBDIR= gtk/v1.3
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= pango.0:${PORTSDIR}/x11-toolkits/pango \
+ glib-1.3.5:${PORTSDIR}/devel/glib13
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>