aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/dasher
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
committermarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
commit0b42143dea1a55d0f1f6d09704bbc131e1b633ed (patch)
treebc54902eb18f738e45a91362b2b0faf1ec6d04fa /accessibility/dasher
parent773c9ca4ac44ac67652d01f1e985e4df8dab5301 (diff)
downloadfreebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.gz
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.zst
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Diffstat (limited to 'accessibility/dasher')
-rw-r--r--accessibility/dasher/Makefile7
-rw-r--r--accessibility/dasher/distinfo4
-rw-r--r--accessibility/dasher/files/patch-Src_Gtk2_speech.cc15
-rw-r--r--accessibility/dasher/pkg-plist77
4 files changed, 84 insertions, 19 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index c93d7ee10dfe..8ada000f1a79 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dasher
-PORTVERSION= 3.2.11
-PORTREVISION= 4
+PORTVERSION= 3.2.15
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
@@ -22,9 +21,11 @@ RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi
+USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
+ libwnck
WANT_GNOME= yes
USE_LIBTOOL_VER=15
+INSTALLS_OMF= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/accessibility/dasher/distinfo b/accessibility/dasher/distinfo
index 9c279f0959c9..02812ef26e43 100644
--- a/accessibility/dasher/distinfo
+++ b/accessibility/dasher/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/dasher-3.2.11.tar.bz2) = f3180d8ec786c1ea158cc5ac0894856c
-SIZE (gnome2/dasher-3.2.11.tar.bz2) = 2651970
+MD5 (gnome2/dasher-3.2.15.tar.bz2) = a3fa85e32c94c69476e12ecba7d257e7
+SIZE (gnome2/dasher-3.2.15.tar.bz2) = 8981223
diff --git a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
index 93031e47f2c4..05d3c3b835fd 100644
--- a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
+++ b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
@@ -1,20 +1,11 @@
---- Src/Gtk2/speech.cc.orig Fri Jul 30 15:28:41 2004
-+++ Src/Gtk2/speech.cc Sun Feb 13 20:15:46 2005
-@@ -46,7 +46,7 @@
-
- voices = GNOME_Speech_SynthesisDriver_getAllVoices (rv, &ev);
-
-- if (voices==NULL || BONOBO_EX (&ev)) {
-+ if (voices==NULL || BONOBO_EX (&ev) || voices->_length==0) {
- printf(_("Unable to initialize voices"));
- speaker=NULL;
- return;
+--- Src/Gtk2/speech.cc.orig Fri Sep 17 06:53:53 2004
++++ Src/Gtk2/speech.cc Sat Feb 26 01:00:12 2005
@@ -78,7 +78,8 @@
void teardown_speech() {
bonobo_object_release_unref (speaker, NULL);
- CORBA_free (voices);
-+ if (voices != NULL && voices->_length != 0)
++ if (voices != NULL && !BONOBO_EX (&ev) && voices->_length != 0)
+ CORBA_free (voices);
CORBA_exception_free (&ev);
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index 2d6c939517fc..1be84180bf55 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -1,6 +1,8 @@
bin/dasher
share/gnome/applications/dasher.desktop
share/gnome/dasher/alphabet.Armenian.xml
+share/gnome/dasher/alphabet.Assamese.xml
+share/gnome/dasher/alphabet.Austen.xml
share/gnome/dasher/alphabet.Azerbaijani.xml
share/gnome/dasher/alphabet.Belarusian.xml
share/gnome/dasher/alphabet.Bengali.xml
@@ -9,23 +11,37 @@ share/gnome/dasher/alphabet.Esperanto.xml
share/gnome/dasher/alphabet.Estonian.xml
share/gnome/dasher/alphabet.Filipino.xml
share/gnome/dasher/alphabet.Greek.xml
+share/gnome/dasher/alphabet.Gujarati.xml
share/gnome/dasher/alphabet.Hebrew.xml
+share/gnome/dasher/alphabet.Hindi.xml
share/gnome/dasher/alphabet.Icelandic.xml
share/gnome/dasher/alphabet.Igbo.xml
share/gnome/dasher/alphabet.Indonesian.xml
share/gnome/dasher/alphabet.IrishGaelic.xml
+share/gnome/dasher/alphabet.Japanese.xml
+share/gnome/dasher/alphabet.Joyo.xml
+share/gnome/dasher/alphabet.Joyo2.xml
+share/gnome/dasher/alphabet.Kannada.xml
+share/gnome/dasher/alphabet.Katakana.xml
share/gnome/dasher/alphabet.Malay.xml
+share/gnome/dasher/alphabet.Malayalam.xml
+share/gnome/dasher/alphabet.Marathi.xml
share/gnome/dasher/alphabet.Moldavian.xml
share/gnome/dasher/alphabet.Ndebele.xml
+share/gnome/dasher/alphabet.Oriya.xml
+share/gnome/dasher/alphabet.Punjabi.xml
share/gnome/dasher/alphabet.Romanian.xml
share/gnome/dasher/alphabet.Sami.xml
share/gnome/dasher/alphabet.ScotsGaelic.xml
share/gnome/dasher/alphabet.Sepedi.xml
share/gnome/dasher/alphabet.Sesotho.xml
+share/gnome/dasher/alphabet.Sinhala.xml
share/gnome/dasher/alphabet.Slovak.xml
share/gnome/dasher/alphabet.Slovenian.xml
share/gnome/dasher/alphabet.Swati.xml
share/gnome/dasher/alphabet.Tajik.xml
+share/gnome/dasher/alphabet.Tamil.xml
+share/gnome/dasher/alphabet.Telugu.xml
share/gnome/dasher/alphabet.Thai.xml
share/gnome/dasher/alphabet.Tsonga.xml
share/gnome/dasher/alphabet.Tswana.xml
@@ -34,12 +50,20 @@ share/gnome/dasher/alphabet.Vietnamese.xml
share/gnome/dasher/alphabet.Xhosa.xml
share/gnome/dasher/alphabet.Yoruba.xml
share/gnome/dasher/alphabet.Zulu.xml
+share/gnome/dasher/alphabet.afrikaans.xml
share/gnome/dasher/alphabet.albanian.xml
+share/gnome/dasher/alphabet.arabic.xml
+share/gnome/dasher/alphabet.bengali.xml
+share/gnome/dasher/alphabet.bopomofo.xml
+share/gnome/dasher/alphabet.catalan.xml
+share/gnome/dasher/alphabet.chinese.xml
+share/gnome/dasher/alphabet.chineseRuby.xml
share/gnome/dasher/alphabet.czech.xml
share/gnome/dasher/alphabet.danish.xml
share/gnome/dasher/alphabet.dtd
share/gnome/dasher/alphabet.dutch.xml
share/gnome/dasher/alphabet.english.xml
+share/gnome/dasher/alphabet.english2.xml
share/gnome/dasher/alphabet.finnish.xml
share/gnome/dasher/alphabet.french.xml
share/gnome/dasher/alphabet.german.xml
@@ -50,33 +74,77 @@ share/gnome/dasher/alphabet.hungarian.xml
share/gnome/dasher/alphabet.hungarianLowerCase.xml
share/gnome/dasher/alphabet.ipa.xml
share/gnome/dasher/alphabet.italian.xml
+share/gnome/dasher/alphabet.klingon.xml
share/gnome/dasher/alphabet.korean.xml
share/gnome/dasher/alphabet.mongolian.xml
+share/gnome/dasher/alphabet.mongolian2.xml
share/gnome/dasher/alphabet.norwegian.xml
+share/gnome/dasher/alphabet.persian.xml
+share/gnome/dasher/alphabet.pinyin.xml
share/gnome/dasher/alphabet.polish.xml
share/gnome/dasher/alphabet.portuguese.xml
share/gnome/dasher/alphabet.russian.xml
share/gnome/dasher/alphabet.spanish.xml
share/gnome/dasher/alphabet.swahili.xml
share/gnome/dasher/alphabet.swedish.xml
+share/gnome/dasher/alphabet.thaana.xml
+share/gnome/dasher/alphabet.venda.xml
share/gnome/dasher/alphabet.welsh.xml
share/gnome/dasher/alphabet.xsl
share/gnome/dasher/colour.dtd
share/gnome/dasher/colour.hiragana.xml
share/gnome/dasher/colour.xml
share/gnome/dasher/dasher.glade
+share/gnome/dasher/training_Afrikaans_ZA.txt
+share/gnome/dasher/training_Assamese_IN.txt
+share/gnome/dasher/training_English_ZA.txt
+share/gnome/dasher/training_Esperanto_XX.txt
+share/gnome/dasher/training_Gujarati_IN.txt
+share/gnome/dasher/training_Hindi_IN.txt
+share/gnome/dasher/training_Japanese_JP.txt
+share/gnome/dasher/training_Kannada_IN.txt
+share/gnome/dasher/training_Kashmiri_IN.txt
+share/gnome/dasher/training_Malayalam_IN.txt
+share/gnome/dasher/training_Marathi_IN.txt
+share/gnome/dasher/training_Ndebele_ZA.txt
+share/gnome/dasher/training_Oriya_IN.txt
+share/gnome/dasher/training_Punjabi_IN.txt
+share/gnome/dasher/training_Punjabi_IPA_IN.txt
+share/gnome/dasher/training_Sepedi_ZA.txt
+share/gnome/dasher/training_Sesotho_ZA.txt
+share/gnome/dasher/training_Sinhala_IN.txt
+share/gnome/dasher/training_Swati_ZA.txt
+share/gnome/dasher/training_Tamil_IN.txt
+share/gnome/dasher/training_Telugu_IN.txt
+share/gnome/dasher/training_Tsonga_ZA.txt
+share/gnome/dasher/training_Tswana_ZA.txt
+share/gnome/dasher/training_Urdu_PK.txt
+share/gnome/dasher/training_Venda_ZA.txt
+share/gnome/dasher/training_Xhosa_ZA.txt
+share/gnome/dasher/training_Zulu_ZA.txt
+share/gnome/dasher/training_albanian_SQ.txt
+share/gnome/dasher/training_bengali_BD.txt
+share/gnome/dasher/training_bengali_bn.txt
share/gnome/dasher/training_czech_CS.txt
+share/gnome/dasher/training_danish_DK.txt
share/gnome/dasher/training_dutch_NL.txt
share/gnome/dasher/training_english_GB.txt
+share/gnome/dasher/training_finnish_FI.txt
share/gnome/dasher/training_french_FR.txt
share/gnome/dasher/training_german_DE.txt
+share/gnome/dasher/training_greek_GR.txt
share/gnome/dasher/training_hebrew_IL.txt
share/gnome/dasher/training_hiragana60_JP.txt
share/gnome/dasher/training_hiragana83_JP.txt
+share/gnome/dasher/training_hungarian_HU.txt
share/gnome/dasher/training_italian_IT.txt
share/gnome/dasher/training_mongolian_MN.txt
+share/gnome/dasher/training_polish_PL.txt
share/gnome/dasher/training_portuguese_BR.txt
share/gnome/dasher/training_russian_RU.txt
+share/gnome/dasher/training_spanish_ES.txt
+share/gnome/dasher/training_swahili_KE.txt
+share/gnome/dasher/training_swedish_SE.txt
share/gnome/dasher/training_welsh_GB.txt
share/gnome/help/dasher/C/dasher.xml
share/gnome/help/dasher/C/figures/figure2.png
@@ -89,12 +157,12 @@ share/gnome/help/dasher/C/figures/prefs5.png
share/gnome/help/dasher/C/version.xml
share/gnome/icons/dasher.png
share/gnome/omf/dasher/dasher-C.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/dasher/dasher-C.omf 2>/dev/null || /usr/bin/true
share/locale/ar/LC_MESSAGES/dasher.mo
share/locale/az/LC_MESSAGES/dasher.mo
share/locale/be/LC_MESSAGES/dasher.mo
share/locale/bg/LC_MESSAGES/dasher.mo
share/locale/bn/LC_MESSAGES/dasher.mo
+share/locale/bs/LC_MESSAGES/dasher.mo
share/locale/ca/LC_MESSAGES/dasher.mo
share/locale/cs/LC_MESSAGES/dasher.mo
share/locale/cy/LC_MESSAGES/dasher.mo
@@ -108,7 +176,9 @@ share/locale/et/LC_MESSAGES/dasher.mo
share/locale/fi/LC_MESSAGES/dasher.mo
share/locale/fr/LC_MESSAGES/dasher.mo
share/locale/ga/LC_MESSAGES/dasher.mo
+share/locale/gu/LC_MESSAGES/dasher.mo
share/locale/he/LC_MESSAGES/dasher.mo
+share/locale/hi/LC_MESSAGES/dasher.mo
share/locale/hr/LC_MESSAGES/dasher.mo
share/locale/hu/LC_MESSAGES/dasher.mo
share/locale/id/LC_MESSAGES/dasher.mo
@@ -116,8 +186,10 @@ share/locale/it/LC_MESSAGES/dasher.mo
share/locale/ja/LC_MESSAGES/dasher.mo
share/locale/ko/LC_MESSAGES/dasher.mo
share/locale/lt/LC_MESSAGES/dasher.mo
+share/locale/mk/LC_MESSAGES/dasher.mo
share/locale/mn/LC_MESSAGES/dasher.mo
share/locale/ms/LC_MESSAGES/dasher.mo
+share/locale/nb/LC_MESSAGES/dasher.mo
share/locale/ne/LC_MESSAGES/dasher.mo
share/locale/nl/LC_MESSAGES/dasher.mo
share/locale/no/LC_MESSAGES/dasher.mo
@@ -132,6 +204,8 @@ share/locale/sq/LC_MESSAGES/dasher.mo
share/locale/sr/LC_MESSAGES/dasher.mo
share/locale/sr@Latn/LC_MESSAGES/dasher.mo
share/locale/sv/LC_MESSAGES/dasher.mo
+share/locale/ta/LC_MESSAGES/dasher.mo
+share/locale/tk/LC_MESSAGES/dasher.mo
share/locale/tr/LC_MESSAGES/dasher.mo
share/locale/uk/LC_MESSAGES/dasher.mo
share/locale/zh_CN/LC_MESSAGES/dasher.mo
@@ -141,4 +215,3 @@ share/locale/zh_TW/LC_MESSAGES/dasher.mo
@dirrm share/gnome/help/dasher/C
@dirrm share/gnome/help/dasher
@dirrm share/gnome/dasher
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/dasher/dasher-C.omf 2>/dev/null || /usr/bin/true