aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/dasher
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
committermarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
commite83248f2b323aa90dfea75471b86ccc444a80f88 (patch)
treef4fc2dbabf96cb67c502479d9fc13f40bf0d0108 /accessibility/dasher
parent52dd0c5de1d6a7165dc355ecf161f52bb7dbbfda (diff)
downloadfreebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.gz
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.zst
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.zip
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Diffstat (limited to 'accessibility/dasher')
-rw-r--r--accessibility/dasher/Makefile5
-rw-r--r--accessibility/dasher/distinfo6
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp11
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp15
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp17
-rw-r--r--accessibility/dasher/files/patch-configure18
-rw-r--r--accessibility/dasher/pkg-plist49
7 files changed, 78 insertions, 43 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index a6d827bb0c78..81f4fa743cda 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -3,11 +3,11 @@
# Whom: lewiz <purple@lewiz.net>
#
# $FreeBSD$
-# $MCom: ports/accessibility/dasher/Makefile,v 1.44 2006/09/03 21:33:52 marcus Exp $
+# $MCom: ports/accessibility/dasher/Makefile,v 1.50 2007/03/12 20:16:34 mezz Exp $
#
PORTNAME= dasher
-PORTVERSION= 4.2.2
+PORTVERSION= 4.4.0
PORTEPOCH= 1
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
@@ -34,6 +34,7 @@ USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= dasher.schemas
MAN1= dasher.1
.include <bsd.port.pre.mk>
diff --git a/accessibility/dasher/distinfo b/accessibility/dasher/distinfo
index 062659c4090c..2c598e410e00 100644
--- a/accessibility/dasher/distinfo
+++ b/accessibility/dasher/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/dasher-4.2.2.tar.bz2) = eff0aeda6c02b03263c4712f56bd3b1c
-SHA256 (gnome2/dasher-4.2.2.tar.bz2) = a51a3bf9a3a1b28a5e9dacc82bad14903a93389a0df92b289e8c2f4180e8bdcf
-SIZE (gnome2/dasher-4.2.2.tar.bz2) = 5625199
+MD5 (gnome2/dasher-4.4.0.tar.bz2) = e47684793d29904f64370393234cf604
+SHA256 (gnome2/dasher-4.4.0.tar.bz2) = 66fab7ac772fa1cb2fad1fe9183effa73d345fec364942e1dbc8084600d1d73a
+SIZE (gnome2/dasher-4.4.0.tar.bz2) = 6741569
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp b/accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp
new file mode 100644
index 000000000000..baf470649d47
--- /dev/null
+++ b/accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp
@@ -0,0 +1,11 @@
+--- Src/DasherCore/BasicLog.cpp.orig Tue Dec 5 22:01:38 2006
++++ Src/DasherCore/BasicLog.cpp Tue Dec 5 22:02:14 2006
+@@ -87,7 +87,7 @@ std::string CBasicLog::GetDateStamp() {
+ szTimeLine = ctime(&(sTimeBuffer.time));
+ #else
+ gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
+- szTimeLine = ctime(&(sTimeBuffer.tv_sec));
++ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
+ #endif
+
+ return std::string(szTimeLine).substr(0, 24);
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp b/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp
index 6b5fdba4a5ad..ec71875602fd 100644
--- a/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp
+++ b/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp
@@ -1,6 +1,6 @@
---- Src/DasherCore/FileLogger.cpp.orig Fri Apr 21 17:41:01 2006
-+++ Src/DasherCore/FileLogger.cpp Sun Jun 11 07:33:19 2006
-@@ -511,7 +511,7 @@
+--- Src/DasherCore/FileLogger.cpp.orig Sun Dec 3 09:50:34 2006
++++ Src/DasherCore/FileLogger.cpp Sun Dec 3 18:45:55 2006
+@@ -511,7 +511,7 @@ std::string CFileLogger::GetTimeDateStam
szTimeLine = ctime(&(sTimeBuffer.time));
#else
gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
@@ -9,12 +9,3 @@
#endif
// Format is:
-@@ -538,7 +538,7 @@
- #ifdef _WIN32
- sprintf(strMs, "%d", sTimeBuffer.millitm);
- #else
-- sprintf(strMs, "%d", sTimeBuffer.tv_usec / 1000);
-+ sprintf(strMs, "%d", (int) (sTimeBuffer.tv_usec / 1000));
- #endif
- if (strlen(strMs) == 1)
- strTimeStamp += "00";
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp b/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp
index d41cf9bed26b..c10219ff4f4f 100644
--- a/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp
+++ b/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp
@@ -1,6 +1,6 @@
---- Src/DasherCore/TimeSpan.cpp.orig Fri Apr 21 17:41:02 2006
-+++ Src/DasherCore/TimeSpan.cpp Sun Jun 11 09:21:30 2006
-@@ -122,7 +122,7 @@
+--- Src/DasherCore/TimeSpan.cpp.orig Sun Dec 3 09:50:34 2006
++++ Src/DasherCore/TimeSpan.cpp Sun Dec 3 18:47:02 2006
+@@ -122,7 +122,7 @@ string CTimeSpan::GetTimeStamp()
szTimeLine = ctime(&(sTimeBuffer.time));
#else
gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
@@ -9,16 +9,7 @@
#endif
if ((szTimeLine != NULL) && (strlen(szTimeLine) > 18))
-@@ -134,7 +134,7 @@
- #ifdef _WIN32
- sprintf(szMs, "%d", sTimeBuffer.millitm);
- #else
-- sprintf(szMs, "%d", sTimeBuffer.tv_usec / 1000);
-+ sprintf(szMs, "%d", (int) (sTimeBuffer.tv_usec / 1000));
- #endif
- if (strlen(szMs) == 1)
- strTimeStamp += "00";
-@@ -196,7 +196,7 @@
+@@ -196,7 +196,7 @@ string CTimeSpan::GetDateStamp()
szTimeLine = ctime(&(sTimeBuffer.time));
#else
gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
diff --git a/accessibility/dasher/files/patch-configure b/accessibility/dasher/files/patch-configure
index 7ade63c80eaf..bde9cc59ce4f 100644
--- a/accessibility/dasher/files/patch-configure
+++ b/accessibility/dasher/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Wed May 17 00:00:16 2006
-+++ configure Wed May 17 00:01:21 2006
-@@ -24000,7 +24000,7 @@ GTK2BUILD_CFLAGS="$GTK2_CFLAGS $SETTINGS
- if [ x"$WITHDARWIN" = xtrue ]; then
- GTK2BUILD_LIBS="$X_LIBS $GTK2_LIBS $SETTINGS_LIBS $gthread_LIBS $gnome_speech_LIBS $gnome_a11y_LIBS $glade_LIBS $gnome_LIBS $wnck_LIBS $hildon_LIBS"
+--- configure.orig Sun Dec 3 18:59:04 2006
++++ configure Sun Dec 3 18:59:15 2006
+@@ -23152,7 +23152,7 @@ echo "$as_me:$LINENO: result: $have_prog
+ echo "${ECHO_T}$have_prog_gnu_ld" >&6
+
+ if [ x"$have_prog_gnu_ld" = xyes ]; then
+- ed_flags="-Wl,--export-dynamic,"
++ ed_flags="-Wl,--export-dynamic"
else
-- GTK2BUILD_LIBS="$X_LIBS $GTK2_LIBS $SETTINGS_LIBS $gthread_LIBS $gnome_speech_LIBS $gnome_a11y_LIBS $glade_LIBS $gnome_LIBS $wnck_LIBS $hildon_LIBS -Wl,--export-dynamic,"
-+ GTK2BUILD_LIBS="$X_LIBS $GTK2_LIBS $SETTINGS_LIBS $gthread_LIBS $gnome_speech_LIBS $gnome_a11y_LIBS $glade_LIBS $gnome_LIBS $wnck_LIBS $hildon_LIBS -Wl,--export-dynamic"
+ ed_flags=""
fi
-
-
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index 27fbfaa616ba..8dbe0c019691 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -3,7 +3,6 @@ share/gnome/applications/dasher.desktop
share/gnome/dasher/alphabet.AfaanOromo.xml
share/gnome/dasher/alphabet.Armenian.xml
share/gnome/dasher/alphabet.Assamese.xml
-share/gnome/dasher/alphabet.Austen.xml
share/gnome/dasher/alphabet.Azerbaijani.xml
share/gnome/dasher/alphabet.Belarusian.xml
share/gnome/dasher/alphabet.Bulgarian.xml
@@ -105,6 +104,7 @@ share/gnome/dasher/alphabet.latvian.xml
share/gnome/dasher/alphabet.lithuanian.xml
share/gnome/dasher/alphabet.luxembourgish.xml
share/gnome/dasher/alphabet.macedonian.xml
+share/gnome/dasher/alphabet.malagasy.xml
share/gnome/dasher/alphabet.maltese.xml
share/gnome/dasher/alphabet.mongolian.xml
share/gnome/dasher/alphabet.myanmar.xml
@@ -113,7 +113,6 @@ share/gnome/dasher/alphabet.norwegian.xml
share/gnome/dasher/alphabet.occitan.xml
share/gnome/dasher/alphabet.ogham.xml
share/gnome/dasher/alphabet.pashto.xml
-share/gnome/dasher/alphabet.perl.xml
share/gnome/dasher/alphabet.persian.xml
share/gnome/dasher/alphabet.pinyin.xml
share/gnome/dasher/alphabet.polish.xml
@@ -147,11 +146,15 @@ share/gnome/dasher/colour.vowels2.xml
share/gnome/dasher/colour.xml
share/gnome/dasher/controllabels.dtd
share/gnome/dasher/controllabels.xml
-share/gnome/dasher/dasher.glade
+share/gnome/dasher/dasher.compose.glade
+share/gnome/dasher/dasher.direct.glade
+share/gnome/dasher/dasher.fullscreen.glade
+share/gnome/dasher/dasher.traditional.glade
+share/gnome/dasher/dashermaemo.glade
+share/gnome/dasher/dashermaemofullscreen.glade
share/gnome/dasher/training_albanian_SQ.txt
share/gnome/dasher/training_basque_EU.txt
share/gnome/dasher/training_bengali_BD.txt
-share/gnome/dasher/training_bengali_bn.txt
share/gnome/dasher/training_canna_JP.txt
share/gnome/dasher/training_czech_CS.txt
share/gnome/dasher/training_danish_DK.txt
@@ -192,7 +195,41 @@ share/gnome/help/dasher/C/figures/prefs2.png
share/gnome/help/dasher/C/figures/prefs3.png
share/gnome/help/dasher/C/figures/prefs4.png
share/gnome/help/dasher/C/figures/prefs5.png
+share/gnome/help/dasher/fr/dasher.xml
+share/gnome/help/dasher/fr/figures/a-z.gif
+share/gnome/help/dasher/fr/figures/aa-az.gif
+share/gnome/help/dasher/fr/figures/ala-alz.gif
+share/gnome/help/dasher/fr/figures/exampleHad2.png
+share/gnome/help/dasher/fr/figures/exampleHad2a.png
+share/gnome/help/dasher/fr/figures/exampleHad3a.png
+share/gnome/help/dasher/fr/figures/exampleHad4.png
+share/gnome/help/dasher/fr/figures/figure2.png
+share/gnome/help/dasher/fr/figures/main.png
+share/gnome/help/dasher/fr/figures/object.gif
+share/gnome/help/dasher/fr/figures/prefs1.png
+share/gnome/help/dasher/fr/figures/prefs2.png
+share/gnome/help/dasher/fr/figures/prefs3.png
+share/gnome/help/dasher/fr/figures/prefs4.png
+share/gnome/help/dasher/fr/figures/prefs5.png
+share/gnome/help/dasher/sv/dasher.xml
+share/gnome/help/dasher/sv/figures/a-z.gif
+share/gnome/help/dasher/sv/figures/aa-az.gif
+share/gnome/help/dasher/sv/figures/ala-alz.gif
+share/gnome/help/dasher/sv/figures/exampleHad2.png
+share/gnome/help/dasher/sv/figures/exampleHad2a.png
+share/gnome/help/dasher/sv/figures/exampleHad3a.png
+share/gnome/help/dasher/sv/figures/exampleHad4.png
+share/gnome/help/dasher/sv/figures/figure2.png
+share/gnome/help/dasher/sv/figures/main.png
+share/gnome/help/dasher/sv/figures/object.gif
+share/gnome/help/dasher/sv/figures/prefs1.png
+share/gnome/help/dasher/sv/figures/prefs2.png
+share/gnome/help/dasher/sv/figures/prefs3.png
+share/gnome/help/dasher/sv/figures/prefs4.png
+share/gnome/help/dasher/sv/figures/prefs5.png
share/gnome/omf/dasher/dasher-C.omf
+share/gnome/omf/dasher/dasher-fr.omf
+share/gnome/omf/dasher/dasher-sv.omf
share/icons/hicolor/48x48/apps/dasher.png
share/icons/hicolor/scalable/apps/dasher.svg
share/locale/ar/LC_MESSAGES/dasher.mo
@@ -268,6 +305,10 @@ share/locale/zh_CN/LC_MESSAGES/dasher.mo
share/locale/zh_HK/LC_MESSAGES/dasher.mo
share/locale/zh_TW/LC_MESSAGES/dasher.mo
@dirrm share/gnome/omf/dasher
+@dirrm share/gnome/help/dasher/sv/figures
+@dirrm share/gnome/help/dasher/sv
+@dirrm share/gnome/help/dasher/fr/figures
+@dirrm share/gnome/help/dasher/fr
@dirrm share/gnome/help/dasher/C/figures
@dirrm share/gnome/help/dasher/C
@dirrm share/gnome/help/dasher