aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/eflite
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2011-06-10 06:26:55 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2011-06-10 06:26:55 +0800
commit9deaa95d97a2b1485dacd2f0be065dbf37e09d17 (patch)
treeda3d0032989bf8541d95c4fcb8ad2a85bf0c3f08 /accessibility/eflite
parent13d26a54730a44050867b03e50cba85eabfc90e8 (diff)
downloadfreebsd-ports-gnome-9deaa95d97a2b1485dacd2f0be065dbf37e09d17.tar.gz
freebsd-ports-gnome-9deaa95d97a2b1485dacd2f0be065dbf37e09d17.tar.zst
freebsd-ports-gnome-9deaa95d97a2b1485dacd2f0be065dbf37e09d17.zip
Add patch to fix build.
PR: ports/157564 Submitted by: David K. Gerry <David.K.Gerry@GMail.com> Approved by: bapt (mentor)
Diffstat (limited to 'accessibility/eflite')
-rw-r--r--accessibility/eflite/Makefile2
-rw-r--r--accessibility/eflite/files/patch-Makefile.in11
2 files changed, 11 insertions, 2 deletions
diff --git a/accessibility/eflite/Makefile b/accessibility/eflite/Makefile
index 6a7f2171bf94..7ee5eb523e37 100644
--- a/accessibility/eflite/Makefile
+++ b/accessibility/eflite/Makefile
@@ -20,8 +20,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= eflite
-BROKEN= does not link
-
CONFIGURE_ARGS+= --with-audio=freebsd
.if defined(FL_LANG)
CONFIGURE_ARGS+= --with-lang=${FL_LANG}
diff --git a/accessibility/eflite/files/patch-Makefile.in b/accessibility/eflite/files/patch-Makefile.in
new file mode 100644
index 000000000000..f5ac9ffa523b
--- /dev/null
+++ b/accessibility/eflite/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- ./Makefile.in.orig 2007-01-18 19:01:09.000000000 -0500
++++ ./Makefile.in 2011-05-27 12:55:15.000000000 -0400
+@@ -34,7 +34,7 @@
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
+
+ fs.o: fs.c
+- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
++ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
+
+ tone.o: tone.c
+ $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<