aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/gnopernicus
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /accessibility/gnopernicus
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'accessibility/gnopernicus')
-rw-r--r--accessibility/gnopernicus/Makefile9
-rw-r--r--accessibility/gnopernicus/distinfo4
-rw-r--r--accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c13
-rw-r--r--accessibility/gnopernicus/files/patch-gnopi_gnopi.c28
-rw-r--r--accessibility/gnopernicus/files/patch-srcore_srbrl.c50
-rw-r--r--accessibility/gnopernicus/files/patch-srcore_srmain.c26
-rw-r--r--accessibility/gnopernicus/files/patch-srlow_libsrlow_SRLow.c13
-rw-r--r--accessibility/gnopernicus/files/patch-srlow_libsrlow_SRObject.c14
-rw-r--r--accessibility/gnopernicus/pkg-plist2
9 files changed, 22 insertions, 137 deletions
diff --git a/accessibility/gnopernicus/Makefile b/accessibility/gnopernicus/Makefile
index 335bbdcaa136..e91aa26cdf10 100644
--- a/accessibility/gnopernicus/Makefile
+++ b/accessibility/gnopernicus/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/accessibility/gnopernicus/Makefile,v 1.63 2005/10/12 00:10:26 marcus Exp $
#
PORTNAME= gnopernicus
-PORTVERSION= 0.10.9
+PORTVERSION= 0.12.0
CATEGORIES= accessibility x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -23,13 +24,13 @@ INSTALLS_OMF= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui atspi gnomespeech
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV= SED="${SED}"
GCONF_SCHEMAS= brlmonitor.schemas gnopernicus.schemas remote.schemas
-SHLIB_VERSION= 9
+SHLIB_VERSION= 0
PLIST_SUB= SHLIB_VERSION=${SHLIB_VERSION}
post-patch:
diff --git a/accessibility/gnopernicus/distinfo b/accessibility/gnopernicus/distinfo
index 814639f0a3f1..5b4907a63e3c 100644
--- a/accessibility/gnopernicus/distinfo
+++ b/accessibility/gnopernicus/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnopernicus-0.10.9.tar.bz2) = dd36c9b729344153812918c03dd84b12
-SIZE (gnome2/gnopernicus-0.10.9.tar.bz2) = 2036421
+MD5 (gnome2/gnopernicus-0.12.0.tar.bz2) = 8228afc6b98306207349df150592b83b
+SIZE (gnome2/gnopernicus-0.12.0.tar.bz2) = 2202137
diff --git a/accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c b/accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c
deleted file mode 100644
index 3a2d38735abb..000000000000
--- a/accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- braille/libbrl/brlxml.c.orig Tue Aug 3 14:50:31 2004
-+++ braille/libbrl/brlxml.c Tue Aug 3 14:50:48 2004
-@@ -730,9 +730,9 @@
- /* fprintf (stderr, "\n attr_val; %s", *attrs); */
- if (g_strcasecmp ((gchar*)*attrs, "mode") == 0)
- {
-- ++attrs;
- gint16 new_offset = 0;
- gshort sign = 1;
-+ ++attrs;
-
- attr_val = g_strdup ((gchar*)*attrs);
- tattr_val = g_strdup (attr_val);
diff --git a/accessibility/gnopernicus/files/patch-gnopi_gnopi.c b/accessibility/gnopernicus/files/patch-gnopi_gnopi.c
deleted file mode 100644
index ee014bef5a98..000000000000
--- a/accessibility/gnopernicus/files/patch-gnopi_gnopi.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- gnopi/gnopi.c.orig Mon Dec 20 23:47:10 2004
-+++ gnopi/gnopi.c Mon Dec 20 23:48:21 2004
-@@ -530,6 +530,7 @@
- GladeXML *xml = NULL;
- gint response_id;
- gboolean accessibility_on;
-+ AtkObject *obj;
-
- /* check if accessibility flag is TRUE */
- accessibility_on = gnopiconf_get_bool (ACCESSIBILITY_GCONF_KEY,
-@@ -550,7 +551,7 @@
-
- g_object_unref (G_OBJECT (xml));
-
-- AtkObject *obj = gtk_widget_get_accessible (dialog);
-+ obj = gtk_widget_get_accessible (dialog);
- atk_object_set_role (obj, ATK_ROLE_ALERT);
-
- response_id = gtk_dialog_run (GTK_DIALOG (dialog));
-@@ -570,7 +571,7 @@
-
- g_object_unref (G_OBJECT (xml));
-
-- AtkObject *obj = gtk_widget_get_accessible (dialog);
-+ obj = gtk_widget_get_accessible (dialog);
- atk_object_set_role (obj, ATK_ROLE_ALERT);
-
- response_id = gtk_dialog_run (GTK_DIALOG (dialog));
diff --git a/accessibility/gnopernicus/files/patch-srcore_srbrl.c b/accessibility/gnopernicus/files/patch-srcore_srbrl.c
deleted file mode 100644
index aef29ae8d7d3..000000000000
--- a/accessibility/gnopernicus/files/patch-srcore_srbrl.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- srcore/srbrl.c.orig Wed Mar 23 04:02:10 2005
-+++ srcore/srbrl.c Wed Mar 23 17:32:38 2005
-@@ -763,6 +763,11 @@
- src_braille_load_values (SRCBraille *braille)
- {
- gint default_port = DEFAULT_BRAILLE_PORT_NO;
-+ gint default_pos_sensor;
-+ gint default_opt_sensor;
-+ gchar *default_braille_transaltion_table;
-+ gchar *default_braille_style;
-+ gchar *default_braille_cursor_style;
-
- sru_assert (braille);
-
-@@ -786,7 +791,7 @@
- SET_BRAILLE_CONFIG_DATA (BRAILLE_PORT_NO, CFGT_INT, &braille->port);
- }
-
-- gchar *default_braille_transaltion_table = DEFAULT_BRAILLE_TRANSLATION;
-+ default_braille_transaltion_table = DEFAULT_BRAILLE_TRANSLATION;
- GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_TRANSLATION, CFGT_STRING,
- &braille->translation_table,
- default_braille_transaltion_table);
-@@ -798,22 +803,22 @@
- }
-
-
-- gchar *default_braille_style = DEFAULT_BRAILLE_STYLE;
-+ default_braille_style = DEFAULT_BRAILLE_STYLE;
- GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_STYLE, CFGT_STRING,
- &braille->style,
- default_braille_style);
-
-- gchar *default_braille_cursor_style = DEFAULT_BRAILLE_CURSOR_STYLE;
-+ default_braille_cursor_style = DEFAULT_BRAILLE_CURSOR_STYLE;
- GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_CURSOR_STYLE, CFGT_STRING,
- &braille->cursor_style,
- default_braille_cursor_style);
-
-- gint default_pos_sensor = DEFAULT_BRAILLE_POSITION_SENSOR;
-+ default_pos_sensor = DEFAULT_BRAILLE_POSITION_SENSOR;
- GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_POSITION_SENSOR, CFGT_INT,
- &braille->position_sensor,
- &default_pos_sensor);
-
-- gint default_opt_sensor = DEFAULT_BRAILLE_OPTICAL_SENSOR;
-+ default_opt_sensor = DEFAULT_BRAILLE_OPTICAL_SENSOR;
- GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_OPTICAL_SENSOR, CFGT_INT,
- &braille->optical_sensor,
- &default_opt_sensor);
diff --git a/accessibility/gnopernicus/files/patch-srcore_srmain.c b/accessibility/gnopernicus/files/patch-srcore_srmain.c
deleted file mode 100644
index 7b113f5bad80..000000000000
--- a/accessibility/gnopernicus/files/patch-srcore_srmain.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- srcore/srmain.c.orig Sun May 30 03:08:45 2004
-+++ srcore/srmain.c Sun May 30 03:09:28 2004
-@@ -602,9 +602,10 @@
- sru_assert (config->key);
- if (strcmp (config->key, BRAILLE_DEVICE) == 0)
- {
-+ gboolean rv;
- sru_assert (config->newvalue && config->type == CFGT_STRING);
-
-- gboolean rv = src_braille_set_device ((gchar*)config->newvalue);
-+ rv = src_braille_set_device ((gchar*)config->newvalue);
- if (!rv)
- {
- sru_message ("SR: process config changed for braille: brl_device did not change!!!");
-@@ -636,9 +637,10 @@
- }
- else if (strcmp (config->key, BRAILLE_TRANSLATION) == 0)
- {
-+ gboolean rv;
- sru_assert (config->type == CFGT_STRING && config->newvalue);
-
-- gboolean rv = src_braille_set_translation_table ((gchar*)config->newvalue);
-+ rv = src_braille_set_translation_table ((gchar*)config->newvalue);
-
- if (!rv)
- {
diff --git a/accessibility/gnopernicus/files/patch-srlow_libsrlow_SRLow.c b/accessibility/gnopernicus/files/patch-srlow_libsrlow_SRLow.c
new file mode 100644
index 000000000000..231ee7891606
--- /dev/null
+++ b/accessibility/gnopernicus/files/patch-srlow_libsrlow_SRLow.c
@@ -0,0 +1,13 @@
+--- srlow/libsrlow/SRLow.c.orig Mon Jun 27 04:14:03 2005
++++ srlow/libsrlow/SRLow.c Mon Jun 27 04:14:18 2005
+@@ -666,8 +666,9 @@ srl_get_focused_cell (Accessible *acc_ta
+ for (i = rows; !rv && i <= rowe && count < SRL_MAX_CHILDREN_CNT; i++)
+ for (j = cols; !rv && j <= cole && count < SRL_MAX_CHILDREN_CNT; j++)
+ {
++ Accessible *cell;
+ count++;
+- Accessible *cell = AccessibleTable_getAccessibleAt (table, i, j);
++ cell = AccessibleTable_getAccessibleAt (table, i, j);
+ if (cell)
+ {
+ if (srl_acc_has_state (cell, SPI_STATE_FOCUSED))
diff --git a/accessibility/gnopernicus/files/patch-srlow_libsrlow_SRObject.c b/accessibility/gnopernicus/files/patch-srlow_libsrlow_SRObject.c
deleted file mode 100644
index 86addc0fc0c7..000000000000
--- a/accessibility/gnopernicus/files/patch-srlow_libsrlow_SRObject.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- srlow/libsrlow/SRObject.c.orig Mon Feb 28 17:11:27 2005
-+++ srlow/libsrlow/SRObject.c Mon Feb 28 17:11:41 2005
-@@ -4206,9 +4206,10 @@
- offset = AccessibleText_getCaretOffset (acc_text);
- if (offset == AccessibleText_getCharacterCount (acc_text) && offset > 0)
- {
-+ char *ret;
- offset--;
- last = TRUE;/*the char is the last char in the text*/
-- char *ret = AccessibleText_getTextBeforeOffset (acc_text, offset+1,
-+ ret = AccessibleText_getTextBeforeOffset (acc_text, offset+1,
- SPI_TEXT_BOUNDARY_LINE_START, &line_start_offset, &line_end_offset);
- SPI_freeString (ret);
- if (offset == line_start_offset && offset > 0)
diff --git a/accessibility/gnopernicus/pkg-plist b/accessibility/gnopernicus/pkg-plist
index 74915167f0c8..b43a4644b069 100644
--- a/accessibility/gnopernicus/pkg-plist
+++ b/accessibility/gnopernicus/pkg-plist
@@ -99,9 +99,11 @@ share/locale/en_CA/LC_MESSAGES/gnopernicus.mo
share/locale/en_GB/LC_MESSAGES/gnopernicus.mo
share/locale/es/LC_MESSAGES/gnopernicus.mo
share/locale/eu/LC_MESSAGES/gnopernicus.mo
+share/locale/fa/LC_MESSAGES/gnopernicus.mo
share/locale/fi/LC_MESSAGES/gnopernicus.mo
share/locale/fr/LC_MESSAGES/gnopernicus.mo
share/locale/ga/LC_MESSAGES/gnopernicus.mo
+share/locale/gl/LC_MESSAGES/gnopernicus.mo
share/locale/gu/LC_MESSAGES/gnopernicus.mo
share/locale/hi/LC_MESSAGES/gnopernicus.mo
share/locale/hr/LC_MESSAGES/gnopernicus.mo