aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/gnopernicus
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /accessibility/gnopernicus
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'accessibility/gnopernicus')
-rw-r--r--accessibility/gnopernicus/Makefile12
-rw-r--r--accessibility/gnopernicus/distinfo6
-rw-r--r--accessibility/gnopernicus/files/patch-configure21
-rw-r--r--accessibility/gnopernicus/pkg-plist11
4 files changed, 41 insertions, 9 deletions
diff --git a/accessibility/gnopernicus/Makefile b/accessibility/gnopernicus/Makefile
index 0279ccad564e..9d28d20836fb 100644
--- a/accessibility/gnopernicus/Makefile
+++ b/accessibility/gnopernicus/Makefile
@@ -3,15 +3,15 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/accessibility/gnopernicus/Makefile,v 1.63 2005/10/12 00:10:26 marcus Exp $
+# $MCom: ports/accessibility/gnopernicus/Makefile,v 1.76 2006/04/14 14:42:45 mezz Exp $
#
PORTNAME= gnopernicus
-PORTVERSION= 0.12.0
+PORTVERSION= 1.0.4
PORTREVISION= 1
CATEGORIES= accessibility x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -20,18 +20,18 @@ COMMENT= Collection of accessibility apps for GNOME 2
LIB_DEPENDS= gnome-mag.2:${PORTSDIR}/accessibility/gnomemag
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui atspi gnomespeech
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV= SED="${SED}"
GCONF_SCHEMAS= brlmonitor.schemas gnopernicus.schemas remote.schemas
-SHLIB_VERSION= 0
+SHLIB_VERSION= 4
PLIST_SUB= SHLIB_VERSION=${SHLIB_VERSION}
post-patch:
diff --git a/accessibility/gnopernicus/distinfo b/accessibility/gnopernicus/distinfo
index 68dc60f7ee90..8823f40f7f3b 100644
--- a/accessibility/gnopernicus/distinfo
+++ b/accessibility/gnopernicus/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnopernicus-0.12.0.tar.bz2) = 8228afc6b98306207349df150592b83b
-SHA256 (gnome2/gnopernicus-0.12.0.tar.bz2) = 7cf15abeea9255594050f29824c67f4de8776b4d8e7a70ae78107675e9c7367b
-SIZE (gnome2/gnopernicus-0.12.0.tar.bz2) = 2202137
+MD5 (gnome2/gnopernicus-1.0.4.tar.bz2) = 4e798c6d08e6096702d316b702801d1d
+SHA256 (gnome2/gnopernicus-1.0.4.tar.bz2) = 1a42e8eb8dde345eb155d21e0a3ec8d57d96d13e989e3ae3ce770e797b9098c9
+SIZE (gnome2/gnopernicus-1.0.4.tar.bz2) = 2306812
diff --git a/accessibility/gnopernicus/files/patch-configure b/accessibility/gnopernicus/files/patch-configure
new file mode 100644
index 000000000000..79dc7a3c1b07
--- /dev/null
+++ b/accessibility/gnopernicus/files/patch-configure
@@ -0,0 +1,21 @@
+--- configure.orig Mon Jan 9 15:02:42 2006
++++ configure Mon Jan 9 15:04:48 2006
+@@ -21635,11 +21635,17 @@
+ TTYNAME_2="/dev/cua/c"
+ TTYNAME_3="/dev/cua/d"
+ ;;
+- FreeBSD-*)
++ FreeBSD-4*|FreeBSD-5*)
+ TTYNAME_0="/dev/cuaa0"
+ TTYNAME_1="/dev/cuaa1"
+ TTYNAME_2="/dev/cuaa2"
+ TTYNAME_3="/dev/cuaa3"
++ ;;
++ FreeBSD-*)
++ TTYNAME_0="/dev/cuad0"
++ TTYNAME_1="/dev/cuad1"
++ TTYNAME_2="/dev/cuaU0"
++ TTYNAME_3="/dev/cuaU1"
+ ;;
+ *)
+ echo "Can't figure out the name of the serial port on this OS"
diff --git a/accessibility/gnopernicus/pkg-plist b/accessibility/gnopernicus/pkg-plist
index f991f6425962..6aa58bfddc98 100644
--- a/accessibility/gnopernicus/pkg-plist
+++ b/accessibility/gnopernicus/pkg-plist
@@ -79,6 +79,9 @@ share/gnome/help/gnopernicus/C/gnopernicus.xml
share/gnome/help/gnopernicus/C/legal.xml
share/gnome/help/gnopernicus/es/gnopernicus.xml
share/gnome/help/gnopernicus/es/legal.xml
+share/gnome/help/gnopernicus/pt_BR/figures/gnopernicus.png
+share/gnome/help/gnopernicus/pt_BR/gnopernicus.xml
+share/gnome/help/gnopernicus/pt_BR/legal.xml
share/gnome/omf/gnopernicus/brlmonitor-C.omf
share/gnome/omf/gnopernicus/brlmonitor-es.omf
share/gnome/omf/gnopernicus/gnopernicus-C.omf
@@ -94,10 +97,12 @@ share/locale/cs/LC_MESSAGES/gnopernicus.mo
share/locale/cy/LC_MESSAGES/gnopernicus.mo
share/locale/da/LC_MESSAGES/gnopernicus.mo
share/locale/de/LC_MESSAGES/gnopernicus.mo
+share/locale/dz/LC_MESSAGES/gnopernicus.mo
share/locale/el/LC_MESSAGES/gnopernicus.mo
share/locale/en_CA/LC_MESSAGES/gnopernicus.mo
share/locale/en_GB/LC_MESSAGES/gnopernicus.mo
share/locale/es/LC_MESSAGES/gnopernicus.mo
+share/locale/et/LC_MESSAGES/gnopernicus.mo
share/locale/eu/LC_MESSAGES/gnopernicus.mo
share/locale/fa/LC_MESSAGES/gnopernicus.mo
share/locale/fi/LC_MESSAGES/gnopernicus.mo
@@ -132,12 +137,18 @@ share/locale/sr/LC_MESSAGES/gnopernicus.mo
share/locale/sr@Latn/LC_MESSAGES/gnopernicus.mo
share/locale/sv/LC_MESSAGES/gnopernicus.mo
share/locale/ta/LC_MESSAGES/gnopernicus.mo
+share/locale/te/LC_MESSAGES/gnopernicus.mo
+share/locale/th/LC_MESSAGES/gnopernicus.mo
share/locale/tr/LC_MESSAGES/gnopernicus.mo
share/locale/uk/LC_MESSAGES/gnopernicus.mo
share/locale/vi/LC_MESSAGES/gnopernicus.mo
share/locale/zh_CN/LC_MESSAGES/gnopernicus.mo
share/locale/zh_TW/LC_MESSAGES/gnopernicus.mo
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/omf/gnopernicus
+@dirrm share/gnome/help/gnopernicus/pt_BR/figures
+@dirrm share/gnome/help/gnopernicus/pt_BR
@dirrm share/gnome/help/gnopernicus/es
@dirrm share/gnome/help/gnopernicus/C
@dirrm share/gnome/help/gnopernicus