aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/gok
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /accessibility/gok
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'accessibility/gok')
-rw-r--r--accessibility/gok/Makefile9
-rw-r--r--accessibility/gok/distinfo6
-rw-r--r--accessibility/gok/files/patch-gok_gok-keyboard.c13
-rw-r--r--accessibility/gok/pkg-plist170
4 files changed, 166 insertions, 32 deletions
diff --git a/accessibility/gok/Makefile b/accessibility/gok/Makefile
index 6c2a461c4cba..0f436c30cc72 100644
--- a/accessibility/gok/Makefile
+++ b/accessibility/gok/Makefile
@@ -3,14 +3,14 @@
# Whom: Adam Weinberger <adamw@freebsd.org>
#
# $FreeBSD$
-#
+# $MCom: ports/accessibility/gok/Makefile,v 1.65 2006/04/27 22:59:43 marcus Exp $
PORTNAME= gok
-PORTVERSION= 1.0.5
+PORTVERSION= 1.0.8
PORTEPOCH= 1
CATEGORIES= accessibility sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.0
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -19,11 +19,12 @@ COMMENT= GNOME On-Screen Keyboard (GOK)
LIB_DEPENDS= gnomespeech.7:${PORTSDIR}/accessibility/gnomespeech
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui atspi libwnck
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
diff --git a/accessibility/gok/distinfo b/accessibility/gok/distinfo
index aa8b7dd04a89..f01d7617b1ef 100644
--- a/accessibility/gok/distinfo
+++ b/accessibility/gok/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gok-1.0.5.tar.bz2) = a9334a0e1dc11bbba817c128503260b0
-SHA256 (gnome2/gok-1.0.5.tar.bz2) = 0c40f2813d113f10da7ef4e534e56d7d47b71805612c4263a1b14e427ae0fa4c
-SIZE (gnome2/gok-1.0.5.tar.bz2) = 1386683
+MD5 (gnome2/gok-1.0.8.tar.bz2) = 48913cafdd9c90067319a619a5f936a3
+SHA256 (gnome2/gok-1.0.8.tar.bz2) = 684cead95f4afd403fed9fdcdfef20adf977119e172c6695f306e68a20631475
+SIZE (gnome2/gok-1.0.8.tar.bz2) = 1151395
diff --git a/accessibility/gok/files/patch-gok_gok-keyboard.c b/accessibility/gok/files/patch-gok_gok-keyboard.c
deleted file mode 100644
index c85f8da0fcb0..000000000000
--- a/accessibility/gok/files/patch-gok_gok-keyboard.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- gok/gok-keyboard.c.orig Fri Nov 5 16:18:02 2004
-+++ gok/gok-keyboard.c Fri Nov 5 16:18:49 2004
-@@ -2519,8 +2519,9 @@
- else if ((pKeyboard->search_type == GOK_SPY_SEARCH_ACTIONABLE) && !did_actionkeys)
- {
- gint action_count, i;
-+ AccessibleAction *action;
- did_actionkeys = TRUE;
-- AccessibleAction *action =
-+ action =
- Accessible_getAction (pNodeAccessible->paccessible);
- if (!action)
- break;
diff --git a/accessibility/gok/pkg-plist b/accessibility/gok/pkg-plist
index a460e052dfd2..2eac98f1075a 100644
--- a/accessibility/gok/pkg-plist
+++ b/accessibility/gok/pkg-plist
@@ -2,6 +2,62 @@ bin/create-branching-keyboard
bin/gok
libdata/bonobo/servers/GNOME_Gok.server
libdata/pkgconfig/gok-1.0.pc
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/gok-GokButton.html
+%%DOCSDIR%%/gok-arraylist.html
+%%DOCSDIR%%/gok-callbacks.html
+%%DOCSDIR%%/gok-command-common.html
+%%DOCSDIR%%/gok-command-edge-data.html
+%%DOCSDIR%%/gok-command-edge.html
+%%DOCSDIR%%/gok-command-graph.html
+%%DOCSDIR%%/gok-command-predictor.html
+%%DOCSDIR%%/gok-command-vertex-data.html
+%%DOCSDIR%%/gok-command-vertex.html
+%%DOCSDIR%%/gok-global.html
+%%DOCSDIR%%/gok-gok-action.html
+%%DOCSDIR%%/gok-gok-branchback-stack.html
+%%DOCSDIR%%/gok-gok-chunker.html
+%%DOCSDIR%%/gok-gok-control.html
+%%DOCSDIR%%/gok-gok-data.html
+%%DOCSDIR%%/gok-gok-editor.html
+%%DOCSDIR%%/gok-gok-feedback.html
+%%DOCSDIR%%/gok-gok-gconf.html
+%%DOCSDIR%%/gok-gok-key.html
+%%DOCSDIR%%/gok-gok-keyboard.html
+%%DOCSDIR%%/gok-gok-keyslotter.html
+%%DOCSDIR%%/gok-gok-log-priv.html
+%%DOCSDIR%%/gok-gok-log-reader.html
+%%DOCSDIR%%/gok-gok-log.html
+%%DOCSDIR%%/gok-gok-modifier.html
+%%DOCSDIR%%/gok-gok-output.html
+%%DOCSDIR%%/gok-gok-page-accessmethod.html
+%%DOCSDIR%%/gok-gok-page-actions.html
+%%DOCSDIR%%/gok-gok-page-feedbacks.html
+%%DOCSDIR%%/gok-gok-page-keysizespace.html
+%%DOCSDIR%%/gok-gok-page-wordcomplete.html
+%%DOCSDIR%%/gok-gok-predictor.html
+%%DOCSDIR%%/gok-gok-scanner.html
+%%DOCSDIR%%/gok-gok-settings-dialog.html
+%%DOCSDIR%%/gok-gok-sound.html
+%%DOCSDIR%%/gok-gok-spy-priv.html
+%%DOCSDIR%%/gok-gok-spy.html
+%%DOCSDIR%%/gok-gok-word-complete.html
+%%DOCSDIR%%/gok-gok.html
+%%DOCSDIR%%/gok-gtkjoyswitch.html
+%%DOCSDIR%%/gok-interface.html
+%%DOCSDIR%%/gok-main.html
+%%DOCSDIR%%/gok-support.html
+%%DOCSDIR%%/gok-switchapi.html
+%%DOCSDIR%%/gok-word-complete.html
+%%DOCSDIR%%/gok.devhelp
+%%DOCSDIR%%/gok.devhelp2
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
share/gnome/applications/gok.desktop
share/gnome/gok/East.png
share/gnome/gok/Keyboard.kbd
@@ -127,6 +183,16 @@ share/gnome/gok/dictionary.txt
share/gnome/gok/direct-selection.xam
share/gnome/gok/directed.xam
share/gnome/gok/dwell-selection.xam
+share/gnome/gok/dz/gok-controls.kbd
+share/gnome/gok/dz/hide.kbd
+share/gnome/gok/dz/launcher.kbd
+share/gnome/gok/dz/main.kbd
+share/gnome/gok/dz/mouse.kbd
+share/gnome/gok/dz/move-resize.kbd
+share/gnome/gok/dz/numberpad.kbd
+share/gnome/gok/dz/quit.kbd
+share/gnome/gok/dz/text-operations.kbd
+share/gnome/gok/dz/valuator.kbd
share/gnome/gok/el/gok-controls.kbd
share/gnome/gok/el/hide.kbd
share/gnome/gok/el/launcher.kbd
@@ -168,6 +234,16 @@ share/gnome/gok/es/numberpad.kbd
share/gnome/gok/es/quit.kbd
share/gnome/gok/es/text-operations.kbd
share/gnome/gok/es/valuator.kbd
+share/gnome/gok/et/gok-controls.kbd
+share/gnome/gok/et/hide.kbd
+share/gnome/gok/et/launcher.kbd
+share/gnome/gok/et/main.kbd
+share/gnome/gok/et/mouse.kbd
+share/gnome/gok/et/move-resize.kbd
+share/gnome/gok/et/numberpad.kbd
+share/gnome/gok/et/quit.kbd
+share/gnome/gok/et/text-operations.kbd
+share/gnome/gok/et/valuator.kbd
share/gnome/gok/eu/gok-controls.kbd
share/gnome/gok/eu/hide.kbd
share/gnome/gok/eu/launcher.kbd
@@ -178,6 +254,16 @@ share/gnome/gok/eu/numberpad.kbd
share/gnome/gok/eu/quit.kbd
share/gnome/gok/eu/text-operations.kbd
share/gnome/gok/eu/valuator.kbd
+share/gnome/gok/fa/gok-controls.kbd
+share/gnome/gok/fa/hide.kbd
+share/gnome/gok/fa/launcher.kbd
+share/gnome/gok/fa/main.kbd
+share/gnome/gok/fa/mouse.kbd
+share/gnome/gok/fa/move-resize.kbd
+share/gnome/gok/fa/numberpad.kbd
+share/gnome/gok/fa/quit.kbd
+share/gnome/gok/fa/text-operations.kbd
+share/gnome/gok/fa/valuator.kbd
share/gnome/gok/fi/gok-controls.kbd
share/gnome/gok/fi/hide.kbd
share/gnome/gok/fi/launcher.kbd
@@ -208,6 +294,16 @@ share/gnome/gok/ga/numberpad.kbd
share/gnome/gok/ga/quit.kbd
share/gnome/gok/ga/text-operations.kbd
share/gnome/gok/ga/valuator.kbd
+share/gnome/gok/gl/gok-controls.kbd
+share/gnome/gok/gl/hide.kbd
+share/gnome/gok/gl/launcher.kbd
+share/gnome/gok/gl/main.kbd
+share/gnome/gok/gl/mouse.kbd
+share/gnome/gok/gl/move-resize.kbd
+share/gnome/gok/gl/numberpad.kbd
+share/gnome/gok/gl/quit.kbd
+share/gnome/gok/gl/text-operations.kbd
+share/gnome/gok/gl/valuator.kbd
share/gnome/gok/glade/gok.glade2
share/gnome/gok/gok-controls.kbd
share/gnome/gok/gok.png
@@ -287,6 +383,16 @@ share/gnome/gok/ja/numberpad.kbd
share/gnome/gok/ja/quit.kbd
share/gnome/gok/ja/text-operations.kbd
share/gnome/gok/ja/valuator.kbd
+share/gnome/gok/ka/gok-controls.kbd
+share/gnome/gok/ka/hide.kbd
+share/gnome/gok/ka/launcher.kbd
+share/gnome/gok/ka/main.kbd
+share/gnome/gok/ka/mouse.kbd
+share/gnome/gok/ka/move-resize.kbd
+share/gnome/gok/ka/numberpad.kbd
+share/gnome/gok/ka/quit.kbd
+share/gnome/gok/ka/text-operations.kbd
+share/gnome/gok/ka/valuator.kbd
share/gnome/gok/ko/gok-controls.kbd
share/gnome/gok/ko/hide.kbd
share/gnome/gok/ko/launcher.kbd
@@ -297,6 +403,16 @@ share/gnome/gok/ko/numberpad.kbd
share/gnome/gok/ko/quit.kbd
share/gnome/gok/ko/text-operations.kbd
share/gnome/gok/ko/valuator.kbd
+share/gnome/gok/ku/gok-controls.kbd
+share/gnome/gok/ku/hide.kbd
+share/gnome/gok/ku/launcher.kbd
+share/gnome/gok/ku/main.kbd
+share/gnome/gok/ku/mouse.kbd
+share/gnome/gok/ku/move-resize.kbd
+share/gnome/gok/ku/numberpad.kbd
+share/gnome/gok/ku/quit.kbd
+share/gnome/gok/ku/text-operations.kbd
+share/gnome/gok/ku/valuator.kbd
share/gnome/gok/latched.png
share/gnome/gok/launcher.kbd
share/gnome/gok/locked.png
@@ -384,16 +500,6 @@ share/gnome/gok/nl/numberpad.kbd
share/gnome/gok/nl/quit.kbd
share/gnome/gok/nl/text-operations.kbd
share/gnome/gok/nl/valuator.kbd
-share/gnome/gok/no/gok-controls.kbd
-share/gnome/gok/no/hide.kbd
-share/gnome/gok/no/launcher.kbd
-share/gnome/gok/no/main.kbd
-share/gnome/gok/no/mouse.kbd
-share/gnome/gok/no/move-resize.kbd
-share/gnome/gok/no/numberpad.kbd
-share/gnome/gok/no/quit.kbd
-share/gnome/gok/no/text-operations.kbd
-share/gnome/gok/no/valuator.kbd
share/gnome/gok/numberpad.kbd
share/gnome/gok/pa/gok-controls.kbd
share/gnome/gok/pa/hide.kbd
@@ -447,6 +553,16 @@ share/gnome/gok/ro/numberpad.kbd
share/gnome/gok/ro/quit.kbd
share/gnome/gok/ro/text-operations.kbd
share/gnome/gok/ro/valuator.kbd
+share/gnome/gok/ru/gok-controls.kbd
+share/gnome/gok/ru/hide.kbd
+share/gnome/gok/ru/launcher.kbd
+share/gnome/gok/ru/main.kbd
+share/gnome/gok/ru/mouse.kbd
+share/gnome/gok/ru/move-resize.kbd
+share/gnome/gok/ru/numberpad.kbd
+share/gnome/gok/ru/quit.kbd
+share/gnome/gok/ru/text-operations.kbd
+share/gnome/gok/ru/valuator.kbd
share/gnome/gok/rw/gok-controls.kbd
share/gnome/gok/rw/hide.kbd
share/gnome/gok/rw/launcher.kbd
@@ -558,6 +674,16 @@ share/gnome/gok/zh_CN/numberpad.kbd
share/gnome/gok/zh_CN/quit.kbd
share/gnome/gok/zh_CN/text-operations.kbd
share/gnome/gok/zh_CN/valuator.kbd
+share/gnome/gok/zh_HK/gok-controls.kbd
+share/gnome/gok/zh_HK/hide.kbd
+share/gnome/gok/zh_HK/launcher.kbd
+share/gnome/gok/zh_HK/main.kbd
+share/gnome/gok/zh_HK/mouse.kbd
+share/gnome/gok/zh_HK/move-resize.kbd
+share/gnome/gok/zh_HK/numberpad.kbd
+share/gnome/gok/zh_HK/quit.kbd
+share/gnome/gok/zh_HK/text-operations.kbd
+share/gnome/gok/zh_HK/valuator.kbd
share/gnome/gok/zh_TW/gok-controls.kbd
share/gnome/gok/zh_TW/hide.kbd
share/gnome/gok/zh_TW/launcher.kbd
@@ -583,14 +709,18 @@ share/locale/cs/LC_MESSAGES/gok.mo
share/locale/cy/LC_MESSAGES/gok.mo
share/locale/da/LC_MESSAGES/gok.mo
share/locale/de/LC_MESSAGES/gok.mo
+share/locale/dz/LC_MESSAGES/gok.mo
share/locale/el/LC_MESSAGES/gok.mo
share/locale/en_CA/LC_MESSAGES/gok.mo
share/locale/en_GB/LC_MESSAGES/gok.mo
share/locale/es/LC_MESSAGES/gok.mo
+share/locale/et/LC_MESSAGES/gok.mo
share/locale/eu/LC_MESSAGES/gok.mo
+share/locale/fa/LC_MESSAGES/gok.mo
share/locale/fi/LC_MESSAGES/gok.mo
share/locale/fr/LC_MESSAGES/gok.mo
share/locale/ga/LC_MESSAGES/gok.mo
+share/locale/gl/LC_MESSAGES/gok.mo
share/locale/gu/LC_MESSAGES/gok.mo
share/locale/hi/LC_MESSAGES/gok.mo
share/locale/hr/LC_MESSAGES/gok.mo
@@ -598,7 +728,9 @@ share/locale/hu/LC_MESSAGES/gok.mo
share/locale/id/LC_MESSAGES/gok.mo
share/locale/it/LC_MESSAGES/gok.mo
share/locale/ja/LC_MESSAGES/gok.mo
+share/locale/ka/LC_MESSAGES/gok.mo
share/locale/ko/LC_MESSAGES/gok.mo
+share/locale/ku/LC_MESSAGES/gok.mo
share/locale/lt/LC_MESSAGES/gok.mo
share/locale/mk/LC_MESSAGES/gok.mo
share/locale/ml/LC_MESSAGES/gok.mo
@@ -607,12 +739,12 @@ share/locale/ms/LC_MESSAGES/gok.mo
share/locale/nb/LC_MESSAGES/gok.mo
share/locale/ne/LC_MESSAGES/gok.mo
share/locale/nl/LC_MESSAGES/gok.mo
-share/locale/no/LC_MESSAGES/gok.mo
share/locale/pa/LC_MESSAGES/gok.mo
share/locale/pl/LC_MESSAGES/gok.mo
share/locale/pt/LC_MESSAGES/gok.mo
share/locale/pt_BR/LC_MESSAGES/gok.mo
share/locale/ro/LC_MESSAGES/gok.mo
+share/locale/ru/LC_MESSAGES/gok.mo
share/locale/rw/LC_MESSAGES/gok.mo
share/locale/sl/LC_MESSAGES/gok.mo
share/locale/sq/LC_MESSAGES/gok.mo
@@ -623,13 +755,21 @@ share/locale/ta/LC_MESSAGES/gok.mo
share/locale/uk/LC_MESSAGES/gok.mo
share/locale/vi/LC_MESSAGES/gok.mo
share/locale/zh_CN/LC_MESSAGES/gok.mo
+share/locale/zh_HK/LC_MESSAGES/gok.mo
share/locale/zh_TW/LC_MESSAGES/gok.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/omf/gok
@dirrm share/gnome/help/gok/C
@dirrm share/gnome/help/gok
@dirrm share/gnome/gok/zh_TW
+@dirrm share/gnome/gok/zh_HK
@dirrm share/gnome/gok/zh_CN
@dirrm share/gnome/gok/vi
@dirrm share/gnome/gok/uk
@@ -640,12 +780,12 @@ share/locale/zh_TW/LC_MESSAGES/gok.mo
@dirrm share/gnome/gok/sq
@dirrm share/gnome/gok/sl
@dirrm share/gnome/gok/rw
+@dirrm share/gnome/gok/ru
@dirrm share/gnome/gok/ro
@dirrm share/gnome/gok/pt_BR
@dirrm share/gnome/gok/pt
@dirrm share/gnome/gok/pl
@dirrm share/gnome/gok/pa
-@dirrm share/gnome/gok/no
@dirrm share/gnome/gok/nl
@dirrm share/gnome/gok/ne
@dirrm share/gnome/gok/nb
@@ -654,7 +794,9 @@ share/locale/zh_TW/LC_MESSAGES/gok.mo
@dirrm share/gnome/gok/ml
@dirrm share/gnome/gok/mk
@dirrm share/gnome/gok/lt
+@dirrm share/gnome/gok/ku
@dirrm share/gnome/gok/ko
+@dirrm share/gnome/gok/ka
@dirrm share/gnome/gok/ja
@dirrm share/gnome/gok/it
@dirrm share/gnome/gok/id
@@ -663,14 +805,18 @@ share/locale/zh_TW/LC_MESSAGES/gok.mo
@dirrm share/gnome/gok/hi
@dirrm share/gnome/gok/gu
@dirrm share/gnome/gok/glade
+@dirrm share/gnome/gok/gl
@dirrm share/gnome/gok/ga
@dirrm share/gnome/gok/fr
@dirrm share/gnome/gok/fi
+@dirrm share/gnome/gok/fa
@dirrm share/gnome/gok/eu
+@dirrm share/gnome/gok/et
@dirrm share/gnome/gok/es
@dirrm share/gnome/gok/en_GB
@dirrm share/gnome/gok/en_CA
@dirrm share/gnome/gok/el
+@dirrm share/gnome/gok/dz
@dirrm share/gnome/gok/de
@dirrm share/gnome/gok/da
@dirrm share/gnome/gok/cy