aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/kdeaccessibility4/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-10 00:52:28 +0800
committermiwi <miwi@FreeBSD.org>2008-08-10 00:52:28 +0800
commit4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08 (patch)
treedb3c1cc1231d3aef48831d470847f62ba1858521 /accessibility/kdeaccessibility4/Makefile
parentd97d7e91b2c078b87375499ca4591297c54f5d50 (diff)
downloadfreebsd-ports-gnome-4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08.tar.gz
freebsd-ports-gnome-4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08.tar.zst
freebsd-ports-gnome-4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08.zip
The KDE FreeBSD team is proud to announce the release of KDE 4.1.0
for FreeBSD. The official KDE 4.1.0 release notes can be found at http://www.kde.org/announcements/4.1/. Some note: * Prefix KDE4 will be install into a custom prefixes namely ${LOCALBASE}/kde4. KDE4 and KDE3 can co-exist * Sound For sound to work, it is necessary to have dbus and hal enabled in your system. Please see the respective documentation on how to enable these. For more Informations see the HEADS UP at ports@ and kde-freebsd@ or our wiki page http://wiki.freebsd.org/KDE4/Install. Have fun!
Diffstat (limited to 'accessibility/kdeaccessibility4/Makefile')
-rw-r--r--accessibility/kdeaccessibility4/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/accessibility/kdeaccessibility4/Makefile b/accessibility/kdeaccessibility4/Makefile
index 63e81307af55..546e8217caa1 100644
--- a/accessibility/kdeaccessibility4/Makefile
+++ b/accessibility/kdeaccessibility4/Makefile
@@ -1,28 +1,30 @@
-# New ports collection makefile for: kdeaccessibility
-# Date created: 19 Jan 2004 18:40:32 EST
-# Whom: Will Andrews <will@FreeBSD.org>
+# New ports collection Makefile for: kdeaccessibility
+# Date created: 2008-01-31
+# Whom: Martin Wilke <miwi@FreeBSD.org>
#
# $FreeBSD$
-#
PORTNAME= kdeaccessibility
-PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTVERSION= ${KDE4_VERSION}
CATEGORIES= accessibility kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-COMMENT= Accessibility applications for KDE
+COMMENT= Accessibility applications for KDE4
-USE_KDELIBS_VER=3
-PREFIX= ${KDE_PREFIX}
+LATEST_LINK= ${PORTNAME}4
+USE_KDE4= kdelibs workspace kdeprefix kdehier automoc4
+KDE4_BUILDENV= yes
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
-USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= opengl gui moc rcc uic
+
+CMAKE_ARGS+= -DKDE4_KTTSD_ALSA:BOOL=OFF
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+post-extract:
+ ${MKDIR} ${WRKSRC}
.include <bsd.port.mk>