aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/qt4-accessible
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-04-20 01:08:04 +0800
committerlofi <lofi@FreeBSD.org>2007-04-20 01:08:04 +0800
commit43404bb558fdbf21dfea86b33ff69de82991385e (patch)
tree7a31726ac01ff730b15d92e60de131efbdf5a4c4 /accessibility/qt4-accessible
parent18159a3ac1812e45272d9372ab81e073abaedba1 (diff)
downloadfreebsd-ports-gnome-43404bb558fdbf21dfea86b33ff69de82991385e.tar.gz
freebsd-ports-gnome-43404bb558fdbf21dfea86b33ff69de82991385e.tar.zst
freebsd-ports-gnome-43404bb558fdbf21dfea86b33ff69de82991385e.zip
Rename all binaries in qt4 which conflict with binaries installed by
qt33 to ($binary)-qt4 and adjust dependencies accordingly. This avoids conflicts once X11BASE has been changed to /usr/local and incidentally makes the naming scheme of the qt4 executables in ports equal to that of the Fedora Core and Debian packages.
Diffstat (limited to 'accessibility/qt4-accessible')
-rw-r--r--accessibility/qt4-accessible/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/accessibility/qt4-accessible/Makefile b/accessibility/qt4-accessible/Makefile
index efcbadf07c24..85d1b45d0e07 100644
--- a/accessibility/qt4-accessible/Makefile
+++ b/accessibility/qt4-accessible/Makefile
@@ -18,7 +18,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt accessibility widgets
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4
LIB_DEPENDS= Qt3Support:${PORTSDIR}/devel/qt4-qt3support \
QtCore:${PORTSDIR}/devel/qt4-corelib \
@@ -64,7 +64,7 @@ pre-configure:
${WRKSRC}/qaccessiblebase.pri
${MKDIR} ${WRKSRC}/../../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
post-configure:
${REINPLACE_CMD} -e 's|(test -z.*||g' ${WRKSRC}/Makefile