aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-09 17:01:41 +0800
committerbapt <bapt@FreeBSD.org>2013-07-09 17:01:41 +0800
commitaba173d4af4b6ebec712c90fcf9bba5b269ffccd (patch)
treed7c35785b47733f64566c6b7a7e731ce794694ac /accessibility
parent95187b5ebc0dbe95f4eef22106cfe0deaddb738d (diff)
downloadfreebsd-ports-gnome-aba173d4af4b6ebec712c90fcf9bba5b269ffccd.tar.gz
freebsd-ports-gnome-aba173d4af4b6ebec712c90fcf9bba5b269ffccd.tar.zst
freebsd-ports-gnome-aba173d4af4b6ebec712c90fcf9bba5b269ffccd.zip
Use USES=display:configure instead of custom implementation
While here: - Trim headers - convert USE_GMAKE to USES=gmake
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/accerciser/Makefile26
1 files changed, 2 insertions, 24 deletions
diff --git a/accessibility/accerciser/Makefile b/accessibility/accerciser/Makefile
index 07a1369cec14..d087d37d4a16 100644
--- a/accessibility/accerciser/Makefile
+++ b/accessibility/accerciser/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: accerciser
-# Date created: 2007-09-17
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/accessibility/accerciser/Makefile,v 1.36 2010/04/27 21:38:19 kwm Exp $
-#
PORTNAME= accerciser
PORTVERSION= 1.12.1
@@ -17,34 +13,16 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Interactive Python accessibility explorer for GNOME
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= pygnomedesktop atspi intlhack
USE_PYTHON= yes
-USES= gettext
+USES= gettext gmake display:configure
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-USE_DISPLAY= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= accerciser.schemas
MAN1= accerciser.1
-.if !defined(DISPLAY)
-pre-configure:
- @if [ -f ${WRKDIR}/.Xvfb.pid ]; then \
- ${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill || ${TRUE} ; \
- ${RM} -f ${WRKDIR}/.Xvfb.pid ; \
- fi
- @${LOCALBASE}/bin/Xvfb :1001 -screen 0 800x600x24 > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
- @sleep 5
-
-post-configure:
- @if [ -f ${WRKDIR}/.Xvfb.pid ]; then \
- ${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill || ${TRUE} ; \
- ${RM} -f ${WRKDIR}/.Xvfb.pid ; \
- fi
-.endif
-
.include <bsd.port.mk>