aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /accessibility
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/at-spi/Makefile2
-rw-r--r--accessibility/atk/Makefile2
-rw-r--r--accessibility/gail/Makefile2
-rw-r--r--accessibility/gnome-mag/Makefile2
-rw-r--r--accessibility/gnomemag/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/accessibility/at-spi/Makefile b/accessibility/at-spi/Makefile
index 7c4127cd412f..6ef7247bf96a 100644
--- a/accessibility/at-spi/Makefile
+++ b/accessibility/at-spi/Makefile
@@ -20,7 +20,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intltool gail libbonobo lthack intlhack
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
USE_REINPLACE= yes
CONFIGURE_ARGS= --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/accessibility/atk/Makefile b/accessibility/atk/Makefile
index 55abbe377a57..be46b0402422 100644
--- a/accessibility/atk/Makefile
+++ b/accessibility/atk/Makefile
@@ -18,7 +18,7 @@ COMMENT= A GNOME accessibility toolkit (ATK)
USE_BZIP2= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomehack lthack glib20
CONFIGURE_ARGS= --enable-static \
--disable-gtk-doc \
diff --git a/accessibility/gail/Makefile b/accessibility/gail/Makefile
index a6f1a5526270..6e6c2b7c4863 100644
--- a/accessibility/gail/Makefile
+++ b/accessibility/gail/Makefile
@@ -19,7 +19,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomehack libgnomecanvas lthack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/accessibility/gnome-mag/Makefile b/accessibility/gnome-mag/Makefile
index 70811f7dbe75..5416df80c64e 100644
--- a/accessibility/gnome-mag/Makefile
+++ b/accessibility/gnome-mag/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix atspi libbonobo lthack intlhack
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
diff --git a/accessibility/gnomemag/Makefile b/accessibility/gnomemag/Makefile
index 70811f7dbe75..5416df80c64e 100644
--- a/accessibility/gnomemag/Makefile
+++ b/accessibility/gnomemag/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix atspi libbonobo lthack intlhack
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"