aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/brotli/Makefile
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2017-07-13 03:44:56 +0800
committerbrnrd <brnrd@FreeBSD.org>2017-07-13 03:44:56 +0800
commitfbf424e67fec98e4affddb9790a5ea0ab05801b0 (patch)
treeb828c9924faf3933a09c8c77d59be38037ce3e01 /archivers/brotli/Makefile
parentfad1eba08eaf72ac0731989eb7f598d7552779d8 (diff)
downloadfreebsd-ports-gnome-fbf424e67fec98e4affddb9790a5ea0ab05801b0.tar.gz
freebsd-ports-gnome-fbf424e67fec98e4affddb9790a5ea0ab05801b0.tar.zst
freebsd-ports-gnome-fbf424e67fec98e4affddb9790a5ea0ab05801b0.zip
archivers/brotli: Move and update to 0.6.0
- Move from devel/libbrotli to archivers/brotli - Remove meta-project for library build - Bump epoch for meta 1.0 to upstream 0.6 update - Add MOVED entry - Switch from autoconf to cmake PR: 218813, 218851 Submitted by: Markus Kohlmeyer <rootservice@gmail.com> Approved by: maintainer time-out Differential Revision: https://reviews.freebsd.org/D11290
Diffstat (limited to 'archivers/brotli/Makefile')
-rw-r--r--archivers/brotli/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/archivers/brotli/Makefile b/archivers/brotli/Makefile
new file mode 100644
index 000000000000..404f2f3837b8
--- /dev/null
+++ b/archivers/brotli/Makefile
@@ -0,0 +1,28 @@
+# Created by: Sergey A. Osokin <osa@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= brotli
+PORTVERSION= 0.6.0
+DISTVERSIONPREFIX= v
+PORTEPOCH= 1
+CATEGORIES= archivers devel
+
+MAINTAINER= osa@FreeBSD.org
+COMMENT= Generic-purpose lossless compression algorithm
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+
+USES= cmake compiler:c++0x pkgconfig
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DBUILD_TESTING:BOOL=OFF
+
+post-install:
+ @${LN} -s libbrotlicommon.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libbrotlicommon.so.0
+ @${LN} -s libbrotlidec.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libbrotlidec.so.0
+ @${LN} -s libbrotlienc.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libbrotlienc.so.0
+
+.include <bsd.port.mk>