aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/dpkg/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
committerpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
commit4682c2c61dcb7a63ae78f7c087ba5d0bda84f154 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /archivers/dpkg/Makefile
parent31dd4fd824aafa89c7f4eb95e23f32974c053110 (diff)
downloadfreebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.gz
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.zst
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Diffstat (limited to 'archivers/dpkg/Makefile')
-rw-r--r--archivers/dpkg/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index e144dd4c4aa9..ddb9a1819a5b 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -16,10 +16,9 @@ BUILD_DEPENDS= po4a:${PORTSDIR}/textproc/po4a
RUN_DEPENDS= gmd5sum:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch
-USES= iconv
+USES= gmake iconv
USE_XZ= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_PERL5= yes
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
@@ -35,15 +34,16 @@ CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --libdir=${PREFIX}/libexec \
--disable-compiler-warnings
CONFIGURE_ENV+= PERL_LIBDIR="${PREFIX}/${SITE_PERL_REL}"
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_OFF= --disable-nls
+NLS_USES= gettext
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
MANLANG= "" de fr hu ja pl sv
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.endif
.include "Makefile.man"