aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/gshar+gunshar
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>1996-08-16 22:38:17 +0800
committerpeter <peter@FreeBSD.org>1996-08-16 22:38:17 +0800
commitc4e85665c6a394eb99f9d97a9cd01ef723883d6d (patch)
treee70dbf8d9275baa659a6c82ba9e069e78585f460 /archivers/gshar+gunshar
parent4ea3582352c0c9233a95f5661c844df49803efde (diff)
downloadfreebsd-ports-gnome-c4e85665c6a394eb99f9d97a9cd01ef723883d6d.tar.gz
freebsd-ports-gnome-c4e85665c6a394eb99f9d97a9cd01ef723883d6d.tar.zst
freebsd-ports-gnome-c4e85665c6a394eb99f9d97a9cd01ef723883d6d.zip
Fix shar so that it doesn't generate:
# This shar contains: # length mode name # ------ ---------- ------------------------------------------ # 9525 (null) -rw-r--r-- # 3768 (null) -rw-r--r-- ^^^^^^^^^^^ This is a long/off_t printf problem. The only problem with doing this, is that touching the sources with patch causes it to want to go and regenerate it's locale databases using some gnu tools I've never heard of before. :-( Since patch-ac doesn't actually change any messages, I've cheated and touched the dependency files in post-patch. Please, no pukeing, I know it's a gross hack. ;-)
Diffstat (limited to 'archivers/gshar+gunshar')
-rw-r--r--archivers/gshar+gunshar/Makefile7
-rw-r--r--archivers/gshar+gunshar/files/patch-ac11
2 files changed, 17 insertions, 1 deletions
diff --git a/archivers/gshar+gunshar/Makefile b/archivers/gshar+gunshar/Makefile
index 6839cab74d9e..efb29a745d42 100644
--- a/archivers/gshar+gunshar/Makefile
+++ b/archivers/gshar+gunshar/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 Dec 1994
# Whom: ache
#
-# $Id: Makefile,v 1.5 1995/04/12 04:53:52 asami Exp $
+# $Id: Makefile,v 1.6 1995/04/16 01:44:03 ache Exp $
#
DISTNAME= sharutils-4.1.4
CATEGORIES+= archivers
@@ -15,4 +15,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g --disable-uucode --prefix=${PREFIX}
INSTALL_TARGET= install install-man
+post-patch:
+ @touch ${WRKSRC}/stamp-cod
+ @touch ${WRKSRC}/sharutils.cod
+ @touch ${WRKSRC}/locale.c
+
.include <bsd.port.mk>
diff --git a/archivers/gshar+gunshar/files/patch-ac b/archivers/gshar+gunshar/files/patch-ac
new file mode 100644
index 000000000000..7b018fe3a867
--- /dev/null
+++ b/archivers/gshar+gunshar/files/patch-ac
@@ -0,0 +1,11 @@
+--- shar.c.dist Fri Aug 16 22:19:04 1996
++++ shar.c Fri Aug 16 22:19:36 1996
+@@ -589,7 +589,7 @@
+ static int
+ generate_one_header_line (const char *local_name, const char *restore_name)
+ {
+- fprintf (output, "# %6ld %s %s\n", struct_stat.st_size,
++ fprintf (output, "# %6ld %s %s\n", (long)struct_stat.st_size,
+ mode_string (struct_stat.st_mode), restore_name);
+ return 0;
+ }